summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-25 09:33:01 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-25 09:33:01 +0100
commitf568c992ec0db6b55df2256a1875986c51d266a3 (patch)
tree2bbd29e3dbeaddc8282b3d7c0cf8d132c5d0d58c /dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.0.ebuild
parentdev-libs/libpcre: stable 8.45 for hppa, bug #803449 (diff)
downloadgentoo-f568c992ec0db6b55df2256a1875986c51d266a3.tar.gz
gentoo-f568c992ec0db6b55df2256a1875986c51d266a3.tar.bz2
gentoo-f568c992ec0db6b55df2256a1875986c51d266a3.zip
dev-haskell/hdbc-postgresql: bump up to 2.5.0.0
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/799077 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.0.ebuild')
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.0.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.0.ebuild
new file mode 100644
index 000000000000..829c73553edb
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: +splitbase -buildtests
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-postgresql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL driver for HDBC"
+HOMEPAGE="https://github.com/hdbc/hdbc-postgresql"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/postgresql-7:*
+ dev-haskell/convertible:=[profile?]
+ >=dev-haskell/hdbc-2.2.0:2=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'Cabal >= 1.8 && < 3.3' 'Cabal >= 1.8'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-buildtests \
+ --flag=splitbase
+}