summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-05-24 05:58:04 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-05-24 05:58:14 +0100
commit99fef3753769f1195b74c27d208e2e35b351920b (patch)
tree6014a0057816f8bec4ef758bd8e85f19c5f3263b /dev-haskell/hexpat
parentdev-perl/Devel-Hide: Stabilize 0.1.300 sparc, #791736 (diff)
downloadgentoo-99fef3753769f1195b74c27d208e2e35b351920b.tar.gz
gentoo-99fef3753769f1195b74c27d208e2e35b351920b.tar.bz2
gentoo-99fef3753769f1195b74c27d208e2e35b351920b.zip
dev-haskell/hexpat: drop USE=bundled-expat
Reported-by: Sebastian Pipping Closes: https://bugs.gentoo.org/591136 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hexpat')
-rw-r--r--dev-haskell/hexpat/hexpat-0.20.13.ebuild19
-rw-r--r--dev-haskell/hexpat/metadata.xml55
2 files changed, 10 insertions, 64 deletions
diff --git a/dev-haskell/hexpat/hexpat-0.20.13.ebuild b/dev-haskell/hexpat/hexpat-0.20.13.ebuild
index 01a2c7198d8b..6bdd54151798 100644
--- a/dev-haskell/hexpat/hexpat-0.20.13.ebuild
+++ b/dev-haskell/hexpat/hexpat-0.20.13.ebuild
@@ -1,34 +1,33 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-# ebuild generated by hackport 0.5.3.9999
-#hackport: flags: bundle:bundled-expat
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -bundle
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="XML parser/formatter based on expat"
-HOMEPAGE="http://haskell.org/haskellwiki/Hexpat/"
+HOMEPAGE="https://haskell.org/haskellwiki/Hexpat/"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="bundled-expat"
RDEPEND=">=dev-haskell/list-0.4.2:=[profile?] <dev-haskell/list-0.7:=[profile?]
>=dev-haskell/text-0.5.0.0:=[profile?] <dev-haskell/text-1.3.0.0:=[profile?]
>=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
- >=dev-lang/ghc-7.8.2:=
- !bundled-expat? ( dev-libs/expat )
+ >=dev-lang/ghc-8.4.3:=
+ dev-libs/expat
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
+ >=dev-haskell/cabal-2.2.0.1
"
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag bundled-expat bundle)
+ --flag=-bundle
}
diff --git a/dev-haskell/hexpat/metadata.xml b/dev-haskell/hexpat/metadata.xml
index b858ead0d5ef..b7878815d80d 100644
--- a/dev-haskell/hexpat/metadata.xml
+++ b/dev-haskell/hexpat/metadata.xml
@@ -3,59 +3,6 @@
<pkgmetadata>
<maintainer type="project">
<email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
</maintainer>
- <use>
- <flag name="bundled-expat"> Use bundled expat instead of <pkg>dev-libs/expat</pkg></flag>
- </use>
- <longdescription>
- This package provides a general purpose Haskell XML library using Expat to
- do its parsing (&lt;http://expat.sourceforge.net/&gt; - a fast stream-oriented XML
- parser written in C). It is extensible to any string type, with @String@,
- @ByteString@ and @Text@ provided out of the box.
-
- Basic usage: Parsing a tree (/Tree/), formatting a tree (/Format/).
- Other features: Helpers for processing XML trees (/Proc/), trees annotated with
- XML source location (/Annotated/), extended XML trees with comments,
- processing instructions, etc (/Extended/), XML cursors (/Cursor/),
- SAX-style parse (/SAX/), and access to the low-level interface in case speed
- is paramount (/Internal.IO/).
-
- The design goals are speed, speed, speed, interface simplicity and modularity.
-
- For introduction and examples, see the /Text.XML.Expat.Tree/ module. For benchmarks,
- &lt;http://haskell.org/haskellwiki/Hexpat/&gt;
-
- If you want to do interactive I\/O, an obvious option is to use lazy parsing
- with one of the lazy I\/O functions such as hGetContents. However, this can be
- problematic in some applications because it doesn't handle I\/O errors properly
- and can give no guarantee of timely resource cleanup. In these cases, chunked
- I\/O is a better approach: Take a look at the /hexpat-enumerator/ package.
-
- /IO/ is filed under /Internal/ because it's low-level and most users won't want
- it. The other /Internal/ modules are re-exported by /Annotated/, /Tree/ and /Extended/,
- so you won't need to import them directly.
-
- Credits to Iavor Diatchki and the @xml@ (XML.Light) package for /Proc/ and /Cursor/.
- Thanks to the many contributors.
-
- BOUND VS. UNBOUND THREADS: GHC (at least versions 6.12.X) will spawn threads
- if you call a safe FFI callback from an unbound thread. This can get out of
- control in a busy application. To avoid this, from version 0.19.1 we now delegate
- processing to a single worker thread if the calling thread is not bound.
- This essentially means that hexpat currently won't exploit multicores very well.
- It also means that hexpat may be more efficient on threads spawned with forkOS
- (to give you a bound thread) rather than forkIO.
-
- ChangeLog: 0.15 changes intended to fix a (rare) \"error: a C finalizer called back into Haskell.\"
- that seemed only to happen only on ghc6.12.X; 0.15.1 Fix broken Annotated parse;
- 0.16 switch from mtl to transformers; 0.17 fix mapNodeContainer &amp; rename some things.;
- 0.18 rename defaultEncoding to overrideEncoding. 0.18.3 formatG and indent were demanding list
- items more than once (inefficient in chunked processing); 0.19 add Extended.hs;
- 0.19.1 fix a memory leak introduced in 0.19, delegate parsing to bound thread
- if unbound (see note above); 0.19.2 include expat source code so \'cabal install\' just works
- on Linux, Mac and Windows (thanks Jacob Stanley); 0.19.3 fix misconfiguration of expat
- which broke entity parsing; 0.19.4 bump version constraint for text; 0.19.5 bump text
- to &lt; 0.12 and fix text-0.10.0.1 breakage; 0.19.6 dependency breakage with List;
- 0.19.7 ghc-7.2.1 compatibility; 0.19.8 fix space leak on lazy parse under ghc-7.2.1
- </longdescription>
</pkgmetadata>