summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild')
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild
new file mode 100644
index 000000000000..98d30b5f9155
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="http://github.com/jgm/highlighting-kate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?]
+ <dev-haskell/blaze-html-0.7:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ pcre-light? ( =dev-haskell/pcre-light-0.4*:=[profile?]
+ )
+ !pcre-light? ( dev-haskell/regex-pcre-builtin:=[profile?]
+ )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag pcre-light pcre-light)
+}