summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-05-25 21:26:44 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-05-25 21:28:57 +0100
commit26a7227675587377dbeea9877fa1dddcfe3f5bc6 (patch)
treeb43baf99d7b8e53c54639440bc25517952fd8df6 /dev-haskell/http-conduit
parentkde-apps: Remove KDE PIM 4.14.8 (diff)
downloadgentoo-26a7227675587377dbeea9877fa1dddcfe3f5bc6.tar.gz
gentoo-26a7227675587377dbeea9877fa1dddcfe3f5bc6.tar.bz2
gentoo-26a7227675587377dbeea9877fa1dddcfe3f5bc6.zip
dev-haskell/http-conduit: restore ebuild with stable keywords
This reverts commit adccda875e7eee3d086550adfce016046ce6bed0. Reported-by: Nick Bowler Bug: https://bugs.gentoo.org/584018
Diffstat (limited to 'dev-haskell/http-conduit')
-rw-r--r--dev-haskell/http-conduit/Manifest1
-rw-r--r--dev-haskell/http-conduit/http-conduit-2.1.7.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/http-conduit/Manifest b/dev-haskell/http-conduit/Manifest
index 887674f15e55..233333e325c9 100644
--- a/dev-haskell/http-conduit/Manifest
+++ b/dev-haskell/http-conduit/Manifest
@@ -1,2 +1,3 @@
DIST http-conduit-2.1.10.1.tar.gz 26897 SHA256 36ebae73f7bf984e1062aa6079b935069b49a5b3811ea935194c0cecb8de815f SHA512 be9334d477effb5e691a3fb8faac40abd09a855205cefe0018315fbdca7de0fca00396e7fa66ca64c87ec2ee8d04177a4a2598349cfc3948f21000c4d23a0c72 WHIRLPOOL cfffeda187926a48fdc6e2936025d33a6ff0f108945fdb39ed1ffc25a43b9b3feda8f77813ce9a0c558f143e18ef53c26e9daff77e03a7c38b0acac8823ba265
+DIST http-conduit-2.1.7.2.tar.gz 23333 SHA256 ccd5d034d9c1f185ccf600e7f6d6153df793218233683ba073bab62d5449dc46 SHA512 020eae7a5846a880270b24d85ea4e7c2742c0f701e9e895b4dcaa1856f794fd00e09951e171104a173679d062789e5214ee24e0d63984e7d94d2cb2e5e7fb0ce WHIRLPOOL 10833001140438370ef01d3207562851c38339993f5d16d8c21a3c3c2627d94fbb0d38bccf2004a059ca2702d5567ca259cd9989cd0bf6776cb97073acd23652
DIST http-conduit-2.1.8.tar.gz 23331 SHA256 550d86ea9ee6dd90994a460c5c85ddc861fb5c0f007304dc4a2e2035f980ea3d SHA512 a5791e9cc9a5d8a077a54286e163cf16b388e1c1a71f31989e731ad724de887d96bd985805380b3ad7ed8d0570c8577c38bd1a36567ee38924487c7a200d304d WHIRLPOOL 4671a0557363c9170f28ab947e48a1a38d830c8b2d2843be15bea42db2cf192e20492ea9d22f39bca9826b01b8144a16d5914a84f0df5721a175c5768bab2d89
diff --git a/dev-haskell/http-conduit/http-conduit-2.1.7.2.ebuild b/dev-haskell/http-conduit/http-conduit-2.1.7.2.ebuild
new file mode 100644
index 000000000000..5c0365ce311b
--- /dev/null
+++ b/dev-haskell/http-conduit/http-conduit-2.1.7.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP client package with conduit interface and HTTPS support"
+HOMEPAGE="http://www.yesodweb.com/book/http-conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/conduit-0.5.5:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/http-client-0.4.3:=[profile?] <dev-haskell/http-client-0.5:=[profile?]
+ >=dev-haskell/http-client-tls-0.2.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/blaze-builder
+ dev-haskell/case-insensitive
+ >=dev-haskell/conduit-1.1
+ dev-haskell/conduit-extra
+ >=dev-haskell/connection-0.2
+ dev-haskell/cookie
+ dev-haskell/data-default-class
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/network
+ dev-haskell/streaming-commons
+ dev-haskell/text
+ dev-haskell/utf8-string
+ >=dev-haskell/wai-3.0 <dev-haskell/wai-3.1
+ dev-haskell/wai-conduit
+ >=dev-haskell/warp-3.0.0.2 <dev-haskell/warp-3.2
+ dev-haskell/warp-tls )
+"