summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 10:23:10 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:01:53 +0100
commitff87ca9d1c0ad0d828882163e7a530779250da2b (patch)
treefab01c1b15b856b7b88cc9dd770c0e62038a04c4 /dev-haskell/http-conduit
parentdev-haskell/http-client: bump up to 0.6.4.1 (diff)
downloadgentoo-ff87ca9d1c0ad0d828882163e7a530779250da2b.tar.gz
gentoo-ff87ca9d1c0ad0d828882163e7a530779250da2b.tar.bz2
gentoo-ff87ca9d1c0ad0d828882163e7a530779250da2b.zip
dev-haskell/http-conduit: bump up to 2.3.7.3
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/http-conduit')
-rw-r--r--dev-haskell/http-conduit/Manifest1
-rw-r--r--dev-haskell/http-conduit/http-conduit-2.3.7.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/http-conduit/Manifest b/dev-haskell/http-conduit/Manifest
index ec119b104be2..7ce590b81a6d 100644
--- a/dev-haskell/http-conduit/Manifest
+++ b/dev-haskell/http-conduit/Manifest
@@ -2,3 +2,4 @@ DIST http-conduit-2.1.10.1.tar.gz 26897 BLAKE2B ccce9e4848649fc53305acc51544b259
DIST http-conduit-2.1.7.2.tar.gz 23333 BLAKE2B 6346e1872ee339585d8b92d1b20cab06ed892c7fe861387ebf2f547400c991e792a4d87e570be93671fda9d261cde157d5015f4f833abc6138069534637b440b SHA512 020eae7a5846a880270b24d85ea4e7c2742c0f701e9e895b4dcaa1856f794fd00e09951e171104a173679d062789e5214ee24e0d63984e7d94d2cb2e5e7fb0ce
DIST http-conduit-2.1.8.tar.gz 23331 BLAKE2B cf0c85991a8220f1cdb4bab34e42d58bc1fdf49a48048879efd22d6a1fb78a116edd2475c3165bd0cffb8cc5d9d9c92af2a60fb5ad28e330255daa99279018ec SHA512 a5791e9cc9a5d8a077a54286e163cf16b388e1c1a71f31989e731ad724de887d96bd985805380b3ad7ed8d0570c8577c38bd1a36567ee38924487c7a200d304d
DIST http-conduit-2.2.3.tar.gz 27457 BLAKE2B 411dfa2858a6058baef12f8e120648df7dd7eef0880f8a5e6d3bbcafa879865b47ddc4b3c76b5b651d1c3d7629a35ff8316abce62b0e6d61f6754c96e953de7f SHA512 675e5d81130d670377d2597a583f2ea8185604f115317cd11493127086b837d0552014fb3feb53b7930ef3b063d6339d2556f7a8f3f5568dcc5332e3b504e659
+DIST http-conduit-2.3.7.3.tar.gz 28227 BLAKE2B 9cc2583809410bf7e52244140eda9152d4021699a287a8f99cf5501f854965893b03f661a8f0d266239978e48518be386ec3f3ed5bdf44030638b94b9a95d26c SHA512 0b3733ce031299ee3b93ca44d45a913e384dbfcd43efe5c65076efb5ff8266058ecb07e90f699ebb54d2d37f4a299be79717c3988e72cce631d417ba21ed4d08
diff --git a/dev-haskell/http-conduit/http-conduit-2.3.7.3.ebuild b/dev-haskell/http-conduit/http-conduit-2.3.7.3.ebuild
new file mode 100644
index 000000000000..804e775f1c5b
--- /dev/null
+++ b/dev-haskell/http-conduit/http-conduit-2.3.7.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP client package with conduit interface and HTTPS support"
+HOMEPAGE="http://www.yesodweb.com/book/http-conduit"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # needs network
+
+RDEPEND=">=dev-haskell/aeson-0.8:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ >=dev-haskell/conduit-1.2:=[profile?]
+ >=dev-haskell/conduit-extra-1.1:=[profile?]
+ >=dev-haskell/http-client-0.5.13:=[profile?] <dev-haskell/http-client-0.7:=[profile?]
+ >=dev-haskell/http-client-tls-0.3:=[profile?] <dev-haskell/http-client-tls-0.4:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ >=dev-haskell/void-0.5.5:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/blaze-builder
+ dev-haskell/case-insensitive
+ >=dev-haskell/connection-0.2
+ dev-haskell/cookie
+ dev-haskell/data-default-class
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/network
+ dev-haskell/streaming-commons
+ dev-haskell/temporary
+ dev-haskell/text
+ dev-haskell/unliftio
+ dev-haskell/utf8-string
+ >=dev-haskell/wai-3.0 <dev-haskell/wai-3.3
+ dev-haskell/wai-conduit
+ >=dev-haskell/warp-3.0.0.2 <dev-haskell/warp-3.4
+ dev-haskell/warp-tls )
+"