summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/http/http-4000.2.18.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/http/http-4000.2.18.ebuild')
-rw-r--r--dev-haskell/http/http-4000.2.18.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/http/http-4000.2.18.ebuild b/dev-haskell/http/http-4000.2.18.ebuild
new file mode 100644
index 000000000000..316e862c7a00
--- /dev/null
+++ b/dev-haskell/http/http-4000.2.18.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+#hackport: flags: -warp-tests,-mtl1,-warn-as-error,-old-base,-network23
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="HTTP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library for client-side HTTP"
+HOMEPAGE="https://github.com/haskell/HTTP"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="conduit10 +network-uri"
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-2.7:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
+ !network-uri? ( >=dev-haskell/network-2.2.0.1:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ dev-lang/ghc
+ test? ( >=dev-haskell/httpd-shed-0.4 <dev-haskell/httpd-shed-0.5
+ >=dev-haskell/hunit-1.2.0.1 <dev-haskell/hunit-1.3
+ >=dev-haskell/puremd5-0.2.4 <dev-haskell/puremd5-2.2
+ >=dev-haskell/split-0.1.3 <dev-haskell/split-0.3
+ >=dev-haskell/test-framework-0.2.0 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.0 <dev-haskell/test-framework-hunit-0.4 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag conduit10 conduit10) \
+ --flag=-mtl1 \
+ $(cabal_flag network-uri network-uri) \
+ --flag=-network23 \
+ --flag=-old-base \
+ --flag=-warn-as-error \
+ --flag=-warp-tests
+}