summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-24 00:40:46 -0400
committerSam James <sam@gentoo.org>2022-07-30 06:57:28 +0100
commitaa26f0ab87dfc59485e15465b2b9fcdc5274000e (patch)
treebbd4f2d7e7d50fca2c79840092befad2c88b24ed /dev-haskell/io-streams
parentdev-haskell/zlib-bindings: keyword 0.1.1.5 for ~ppc64 (diff)
downloadgentoo-aa26f0ab87dfc59485e15465b2b9fcdc5274000e.tar.gz
gentoo-aa26f0ab87dfc59485e15465b2b9fcdc5274000e.tar.bz2
gentoo-aa26f0ab87dfc59485e15465b2b9fcdc5274000e.zip
dev-haskell/io-streams: add 1.5.2.1, drop 1.5.2.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/io-streams')
-rw-r--r--dev-haskell/io-streams/Manifest3
-rw-r--r--dev-haskell/io-streams/io-streams-1.5.2.1.ebuild (renamed from dev-haskell/io-streams/io-streams-1.5.2.0.ebuild)39
-rw-r--r--dev-haskell/io-streams/metadata.xml69
3 files changed, 28 insertions, 83 deletions
diff --git a/dev-haskell/io-streams/Manifest b/dev-haskell/io-streams/Manifest
index 1c6f233e10ac..d4ee2a66153f 100644
--- a/dev-haskell/io-streams/Manifest
+++ b/dev-haskell/io-streams/Manifest
@@ -1 +1,2 @@
-DIST io-streams-1.5.2.0.tar.gz 63812 BLAKE2B a555bc0bc365e4e2c28570da34e6c2891ff56a7460ec8a857285a22ea3a4a2b8975139c3024fd90ffec51386646d9ed632754971abef04fd2c358cba5e0a19c6 SHA512 2cb6c9cded0077f1501b0fba576b79e5ebf21ccc2711a91552ec46ef6d5e943e0c1255cdfda381aa8e4d7691b1e450956bedd2fbd4414b13ef7926b0cc3dc4c3
+DIST io-streams-1.5.2.1-rev2.cabal 9916 BLAKE2B ac72adc1e84dc2016db65266141113d26e981d2c057574f02ac4ada94c62f4923265e528f3cd4917142ec32de2880f8607776964628c589355fb3639a222448e SHA512 3b2519b655095bdd6a5c2d1180dbaa2ff750f52a9ee02d893d6b82951e3ca2b6a61b81d694cb1539a0dd4080f223a038d3e92df1b660fa9c4a5626fa62460541
+DIST io-streams-1.5.2.1.tar.gz 64050 BLAKE2B 6533d2cff65e3f7af54b6a652e13a2e75ef4a2b38dad6dec3bd3d299f479e7f6293bb63b27dd1066561d6a1eed9a65fe47910d2f8eec83baffdff532deb53433 SHA512 c86f55714469198bab5a670e8b061e75f3f9ad6576ed1523df543365caac492ba3b54fb6356a898c27fa6394e96874bb636e5b9100cf70e0de0d7f73e91ba9c9
diff --git a/dev-haskell/io-streams/io-streams-1.5.2.0.ebuild b/dev-haskell/io-streams/io-streams-1.5.2.1.ebuild
index 0d44d531e46d..f7a2f97e1d31 100644
--- a/dev-haskell/io-streams/io-streams-1.5.2.0.ebuild
+++ b/dev-haskell/io-streams/io-streams-1.5.2.1.ebuild
@@ -1,44 +1,57 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# ebuild generated by hackport 0.6.6.9999
+# ebuild generated by hackport 0.7.1.1.9999
#hackport: flags: +nointeractivetests
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_HACKAGE_REVISION="2"
inherit haskell-cabal
+CABAL_FILE="${S}/${PN}.cabal"
+CABAL_DISTFILE="${P}-rev${CABAL_HACKAGE_REVISION}.cabal"
+
DESCRIPTION="Simple, composable, and easy-to-use stream I/O"
HOMEPAGE="https://hackage.haskell.org/package/io-streams"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal
+ -> ${CABAL_DISTFILE}"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="+network +zlib"
-RESTRICT=test # requires network access
-
-RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
- >=dev-haskell/bytestring-builder-0.10:=[profile?] <dev-haskell/bytestring-builder-0.11:=[profile?]
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?] <dev-haskell/attoparsec-0.15:=[profile?]
>=dev-haskell/primitive-0.2:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
- >=dev-haskell/text-0.10:=[profile?] <dev-haskell/text-1.3:=[profile?]
>=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.13:=[profile?]
- >=dev-lang/ghc-7.8.2:=
+ >=dev-lang/ghc-8.4.3:=
network? ( >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-3.2:=[profile?] )
zlib? ( >=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?] )
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
+ >=dev-haskell/cabal-2.2.0.1
test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
- >=dev-haskell/mtl-2 <dev-haskell/mtl-3
>=dev-haskell/quickcheck-2.3.0.2 <dev-haskell/quickcheck-3
>=dev-haskell/test-framework-0.6 <dev-haskell/test-framework-0.9
>=dev-haskell/test-framework-hunit-0.2.7 <dev-haskell/test-framework-hunit-0.4
>=dev-haskell/test-framework-quickcheck2-0.2.12.1 <dev-haskell/test-framework-quickcheck2-0.4
zlib? ( >=dev-haskell/zlib-0.5 <dev-haskell/zlib-0.7 ) )
"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${CABAL_DISTFILE}" "${CABAL_FILE}" || die
+
+ # Convert to unix line endings
+ dos2unix "${CABAL_FILE}" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
src_configure() {
haskell-cabal_src_configure \
diff --git a/dev-haskell/io-streams/metadata.xml b/dev-haskell/io-streams/metadata.xml
index 310f0593f2cf..7696ff9ecf64 100644
--- a/dev-haskell/io-streams/metadata.xml
+++ b/dev-haskell/io-streams/metadata.xml
@@ -9,73 +9,4 @@
<flag name="network">Include network support</flag>
<flag name="zlib">Include zlib support</flag>
</use>
- <longdescription>
- /Overview/
-
- The io-streams library contains simple and easy-to-use primitives for I/O
- using streams. Most users will want to import the top-level convenience
- module "System.IO.Streams", which re-exports most of the library:
-
- @
- import System.IO.Streams (InputStream, OutputStream)
- import qualified System.IO.Streams as Streams
- @
-
- For first-time users, @io-streams@ comes with an included tutorial, which can
- be found in the "System.IO.Streams.Tutorial" module.
-
- /Features/
-
- The @io-streams@ user API has two basic types: @InputStream a@ and
- @OutputStream a@, and three fundamental I/O primitives:
-
- @
- \-\- read an item from an input stream
- Streams.read :: InputStream a -&gt; IO (Maybe a)
-
- \-\- push an item back to an input stream
- Streams.unRead :: a -&gt; InputStream a -&gt; IO ()
-
- \-\- write to an output stream
- Streams.write :: Maybe a -&gt; OutputStream a -&gt; IO ()
- @
-
- Streams can be transformed by composition and hooked together with provided combinators:
-
- @
- ghci&gt; Streams.fromList [1,2,3::Int] &gt;&gt;= Streams.map (*10) &gt;&gt;= Streams.toList
- [10,20,30]
- @
-
- Stream composition leaves the original stream accessible:
-
- @
- ghci&gt; input \&lt;- Streams.fromByteString \"long string\"
- ghci&gt; wrapped \&lt;- Streams.takeBytes 4 input
- ghci&gt; Streams.read wrapped
- Just \"long\"
- ghci&gt; Streams.read wrapped
- Nothing
- ghci&gt; Streams.read input
- Just \" string\"
- @
-
- Simple types and operations in the IO monad mean straightforward and simple
- exception handling and resource cleanup using Haskell standard library
- facilities like 'Control.Exception.bracket'.
-
- @io-streams@ comes with:
-
- * functions to use files, handles, concurrent channels, sockets, lists,
- vectors, and more as streams.
-
- * a variety of combinators for wrapping and transforming streams, including
- compression and decompression using zlib, controlling precisely how many
- bytes are read from or written to a stream, buffering output using
- bytestring builders, folds, maps, filters, zips, etc.
-
- * support for parsing from streams using @attoparsec@.
-
- * support for spawning processes and communicating with them using streams.
- </longdescription>
</pkgmetadata>