summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-09-08 06:38:54 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-08 22:23:34 +0100
commitf73ae2259dd9ef9c829b8ac400105f47bf4603ca (patch)
treeffe72886ecd7ddaa461bb1c10bcd73c0a3291602 /dev-haskell/io-streams
parentdev-python/cryptography: Stabilize 3.0 arm64, #741224 (diff)
downloadgentoo-f73ae2259dd9ef9c829b8ac400105f47bf4603ca.tar.gz
gentoo-f73ae2259dd9ef9c829b8ac400105f47bf4603ca.tar.bz2
gentoo-f73ae2259dd9ef9c829b8ac400105f47bf4603ca.zip
dev-haskell/io-streams: bump up to 1.5.2.0
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Jack Todaro <solpeth@posteo.org> Closes: https://github.com/gentoo/gentoo/pull/17461 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/io-streams')
-rw-r--r--dev-haskell/io-streams/Manifest1
-rw-r--r--dev-haskell/io-streams/io-streams-1.5.2.0.ebuild48
-rw-r--r--dev-haskell/io-streams/metadata.xml87
3 files changed, 64 insertions, 72 deletions
diff --git a/dev-haskell/io-streams/Manifest b/dev-haskell/io-streams/Manifest
index 3cb233c7ae27..0b9c495f20dc 100644
--- a/dev-haskell/io-streams/Manifest
+++ b/dev-haskell/io-streams/Manifest
@@ -1,2 +1,3 @@
DIST io-streams-1.3.6.0.tar.gz 61651 BLAKE2B d71a5ba3d264b98d3284470021fc1d9622700b37ef1a67142d12d4d6321233eb28ad5274925e08f9d0c251ee77e25e2187c811d197a9f7b68e33479d8ea602ab SHA512 9ef5a2daa43600796b48104771c71d698f40e29def536e785421b53a310683e7db202b254310a0a5f2d1fa507dcad27c25f328c64fffe796c06d4c0d98ca982d
DIST io-streams-1.5.1.0.tar.gz 64044 BLAKE2B 9a1a4dce626f3a569f4a7866f93d5663e9e4e8b863d1c2332bffbeb2e4481e0a250c84b75ae375144a32473b62538dbd87b53dd0a08034daea855484660aa07a SHA512 01ddf89f09cba429ab600e55994cb6740d4fcdeb23ce85822098d39dbe530a74256d66ea52429798787d9d549db3cd99a5078362b333a7f49c4926e74e0b460c
+DIST io-streams-1.5.2.0.tar.gz 63812 BLAKE2B a555bc0bc365e4e2c28570da34e6c2891ff56a7460ec8a857285a22ea3a4a2b8975139c3024fd90ffec51386646d9ed632754971abef04fd2c358cba5e0a19c6 SHA512 2cb6c9cded0077f1501b0fba576b79e5ebf21ccc2711a91552ec46ef6d5e943e0c1255cdfda381aa8e4d7691b1e450956bedd2fbd4414b13ef7926b0cc3dc4c3
diff --git a/dev-haskell/io-streams/io-streams-1.5.2.0.ebuild b/dev-haskell/io-streams/io-streams-1.5.2.0.ebuild
new file mode 100644
index 000000000000..0d44d531e46d
--- /dev/null
+++ b/dev-haskell/io-streams/io-streams-1.5.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: +nointeractivetests
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Simple, composable, and easy-to-use stream I/O"
+HOMEPAGE="https://hackage.haskell.org/package/io-streams"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network +zlib"
+
+RESTRICT=test # requires network access
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/bytestring-builder-0.10:=[profile?] <dev-haskell/bytestring-builder-0.11:=[profile?]
+ >=dev-haskell/primitive-0.2:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
+ >=dev-haskell/text-0.10:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ network? ( >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-3.2:=[profile?] )
+ zlib? ( >=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
+ >=dev-haskell/mtl-2 <dev-haskell/mtl-3
+ >=dev-haskell/quickcheck-2.3.0.2 <dev-haskell/quickcheck-3
+ >=dev-haskell/test-framework-0.6 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.7 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.2.12.1 <dev-haskell/test-framework-quickcheck2-0.4
+ zlib? ( >=dev-haskell/zlib-0.5 <dev-haskell/zlib-0.7 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network network) \
+ --flag=nointeractivetests \
+ $(cabal_flag zlib zlib)
+}
diff --git a/dev-haskell/io-streams/metadata.xml b/dev-haskell/io-streams/metadata.xml
index 7852149c9343..a86f42647c54 100644
--- a/dev-haskell/io-streams/metadata.xml
+++ b/dev-haskell/io-streams/metadata.xml
@@ -5,20 +5,24 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <use>
+ <flag name="network">Include network support</flag>
+ <flag name="zlib">Include zlib support</flag>
+ </use>
<longdescription>
/Overview/
The io-streams library contains simple and easy-to-use primitives for I/O
using streams. Most users will want to import the top-level convenience
- module "System.IO.Streams", which re-exports most of the library:
+ module &quot;System.IO.Streams&quot;, which re-exports most of the library:
@
- import "System.IO.Streams" (InputStream, OutputStream)
- import qualified "System.IO.Streams" as Streams
+ import System.IO.Streams (InputStream, OutputStream)
+ import qualified System.IO.Streams as Streams
@
For first-time users, @io-streams@ comes with an included tutorial, which can
- be found in the "System.IO.Streams.Tutorial" module.
+ be found in the &quot;System.IO.Streams.Tutorial&quot; module.
/Features/
@@ -27,13 +31,13 @@
@
\-\- read an item from an input stream
- Streams.'System.IO.Streams.read' :: 'System.IO.Streams.InputStream' a -&gt; IO (Maybe a)
+ Streams.read :: InputStream a -&gt; IO (Maybe a)
\-\- push an item back to an input stream
- Streams.'System.IO.Streams.unRead' :: a -&gt; 'System.IO.Streams.InputStream' a -&gt; IO ()
+ Streams.unRead :: a -&gt; InputStream a -&gt; IO ()
\-\- write to an output stream
- Streams.'System.IO.Streams.write' :: Maybe a -&gt; 'System.IO.Streams.OutputStream' a -&gt; IO ()
+ Streams.write :: Maybe a -&gt; OutputStream a -&gt; IO ()
@
Streams can be transformed by composition and hooked together with provided combinators:
@@ -46,19 +50,19 @@
Stream composition leaves the original stream accessible:
@
- ghci&gt; input \&lt;- Streams.fromByteString \"long string\"
+ ghci&gt; input \&lt;- Streams.fromByteString \&quot;long string\&quot;
ghci&gt; wrapped \&lt;- Streams.takeBytes 4 input
ghci&gt; Streams.read wrapped
- Just \"long\"
+ Just \&quot;long\&quot;
ghci&gt; Streams.read wrapped
Nothing
ghci&gt; Streams.read input
- Just \" string\"
+ Just \&quot; string\&quot;
@
Simple types and operations in the IO monad mean straightforward and simple
exception handling and resource cleanup using Haskell standard library
- facilities like 'Control.Exception.bracket'.
+ facilities like &#39;Control.Exception.bracket&#39;.
@io-streams@ comes with:
@@ -73,66 +77,5 @@
* support for parsing from streams using @attoparsec@.
* support for spawning processes and communicating with them using streams.
-
- /ChangeLog/
-
- [@1.1.4.2@] Fixed a build error with network versions older than 2.4.
-
- [@1.1.4.1@] @System.IO.Streams.Network@: scalability improvement: buffers
- for socket reads are now allocated by system malloc rather than
- by pinned pointers in GHC (currently pinned pointer allocation
- takes a global lock).
-
- [@1.1.4.0@] Widened @attoparsec@ and @text@ library dependencies to allow
- the latest versions.
-
- [@1.1.3.0@] Added @System.IO.Streams.ByteString.takeExactly@. Widened
- @network@ dependency to include 2.3. Added a
- @NoInteractiveTests@ flag to selectively disable some tests for
- environments where spawning interactive processes is
- impossible.
-
- [@1.1.2.2@] Allowed newest versions of the @process@, @test-framework@,
- and @text@ libraries.
-
- [@1.1.2.1@] Fixed build error when compiled against attoparsec-0.10.0.x.
-
- [@1.1.2.0@] Added @System.IO.Streams.Concurrent.makeChanPipe@, to create a
- simple concurrent pipe between an @InputStream@/@OutputStream@
- pair.
-
- [@1.1.1.0@] Added @System.IO.Streams.Network.socketToStreamsWithBufferSize@,
- allowing control over the size of the receive buffers used when
- reading from sockets.
-
- [@1.1.0.3@] Fixed an inconsistent version upper bound in the test suite.
-
- [@1.1.0.2@] Fixed a typo in the tutorial.
-
- [@1.1.0.1@] A couple of Haddock markup fixes.
-
- [@1.1.0.0@] Reworked, simplified, and streamlined the internals of the
- library. Exports from "System.IO.Streams.Internal" relying on
- Sources and Sinks were deleted because they are no longer
- necessary: Source(..), Sink(..), defaultPushback,
- withDefaultPushback, nullSource, nullSink, singletonSource,
- simpleSource, sourceToStream, sinkToStream, generatorToSource,
- and consumerToSink.
-
- [@1.0.2.2@] Fixed a bug in which \"takeBytes 0\" was erroneously requesting
- input from the wrapped stream.
-
- [@1.0.2.1@] Fixed a compile error on GHC 7.0.x.
-
- [@1.0.2.0@] Added "System.IO.Streams.Process" (support for communicating
- with system processes using streams), added new functions to
- "System.IO.Streams.Handle" for converting @io-streams@ types to
- 'System.IO.Handle's. (Now you can pass streams from this
- library to places that expect Handles and everything will
- work.)
-
- [@1.0.1.0@] Added 'System.IO.Streams.Combinators.ignoreEof'.
-
- [@1.0.0.1@] Fixed some haddock markup.
</longdescription>
</pkgmetadata>