summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/lens/lens-4.11.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/lens/lens-4.11.ebuild')
-rw-r--r--dev-haskell/lens/lens-4.11.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/dev-haskell/lens/lens-4.11.ebuild b/dev-haskell/lens/lens-4.11.ebuild
new file mode 100644
index 000000000000..59baf01f22f8
--- /dev/null
+++ b/dev-haskell/lens/lens-4.11.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+#hackport: flags: -lib-werror
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Lenses, Folds and Traversals"
+HOMEPAGE="http://github.com/ekmett/lens/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="benchmark-uniplate dump-splices +inlining j old-inline-pragmas safe +test-doctests +test-hlint +test-hunit +test-properties +trustworthy"
+
+RDEPEND=">=dev-haskell/bifunctors-5:=[profile?] <dev-haskell/bifunctors-6:=[profile?]
+ >=dev-haskell/comonad-4:=[profile?] <dev-haskell/comonad-5:=[profile?]
+ >=dev-haskell/contravariant-0.3:=[profile?] <dev-haskell/contravariant-2:=[profile?]
+ >=dev-haskell/distributive-0.3:=[profile?] <dev-haskell/distributive-1:=[profile?]
+ >=dev-haskell/exceptions-0.1.1:=[profile?] <dev-haskell/exceptions-1:=[profile?]
+ >=dev-haskell/free-4:=[profile?] <dev-haskell/free-5:=[profile?]
+ >=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-haskell/kan-extensions-4.2.1:=[profile?] <dev-haskell/kan-extensions-5:=[profile?]
+ >=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parallel-3.1.0.1:=[profile?] <dev-haskell/parallel-3.3:=[profile?]
+ >=dev-haskell/profunctors-5:=[profile?] <dev-haskell/profunctors-6:=[profile?]
+ >=dev-haskell/reflection-1.1.6:=[profile?] <dev-haskell/reflection-2:=[profile?]
+ >=dev-haskell/semigroupoids-5:=[profile?] <dev-haskell/semigroupoids-6:=[profile?]
+ >=dev-haskell/semigroups-0.8.4:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/tagged-0.4.4:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-haskell/transformers-compat-0.4:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/void-0.5:=[profile?] <dev-haskell/void-1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( test-doctests? ( >=dev-haskell/doctest-0.9.1
+ dev-haskell/generic-deriving
+ dev-haskell/nats
+ >=dev-haskell/semigroups-0.9
+ >=dev-haskell/simple-reflect-0.3.1
+ test-properties? ( >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.6
+ >=dev-haskell/test-framework-quickcheck2-0.2
+ >=dev-haskell/test-framework-th-0.2 ) )
+ test-hunit? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/test-framework-0.6
+ >=dev-haskell/test-framework-hunit-0.2
+ >=dev-haskell/test-framework-th-0.2
+ test-properties? ( >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-quickcheck2-0.2 ) ) )
+ test-hlint? ( test-doctests? ( test? ( >=dev-haskell/hlint-1.7 ) )
+ !test-doctests? ( test-hunit? ( test? ( >=dev-haskell/hlint-1.7 ) )
+ !test-hunit? ( test-properties? ( test? ( >=dev-haskell/hlint-1.7
+ >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.6
+ >=dev-haskell/test-framework-quickcheck2-0.2
+ >=dev-haskell/test-framework-th-0.2 ) )
+ !test-properties? ( test? ( >=dev-haskell/hlint-1.7 ) ) ) ) )
+ !test-hlint? ( test? ( !test-doctests? ( !test-hunit? ( test-properties? ( >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.6
+ >=dev-haskell/test-framework-quickcheck2-0.2
+ >=dev-haskell/test-framework-th-0.2 ) ) ) ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag benchmark-uniplate benchmark-uniplate) \
+ $(cabal_flag dump-splices dump-splices) \
+ $(cabal_flag inlining inlining) \
+ $(cabal_flag j j) \
+ --flag=-lib-werror \
+ $(cabal_flag old-inline-pragmas old-inline-pragmas) \
+ $(cabal_flag safe safe) \
+ $(cabal_flag test-doctests test-doctests) \
+ $(cabal_flag test-hlint test-hlint) \
+ $(cabal_flag test-hunit test-hunit) \
+ $(cabal_flag test-properties test-properties) \
+ $(cabal_flag trustworthy trustworthy)
+}