summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:05:51 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:22:00 +0000
commit3516e0bda499b9ae3734b50e7097e3dafeca7909 (patch)
treed38afd98611e8e2edf962fd86948a81d71a2697f /dev-haskell/memory/memory-0.14.1.ebuild
parentdev-haskell/glob: bump up to 0.7.14 (diff)
downloadgentoo-3516e0bda499b9ae3734b50e7097e3dafeca7909.tar.gz
gentoo-3516e0bda499b9ae3734b50e7097e3dafeca7909.tar.bz2
gentoo-3516e0bda499b9ae3734b50e7097e3dafeca7909.zip
dev-haskell/memory: bump up to 0.14.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/memory/memory-0.14.1.ebuild')
-rw-r--r--dev-haskell/memory/memory-0.14.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/memory/memory-0.14.1.ebuild b/dev-haskell/memory/memory-0.14.1.ebuild
new file mode 100644
index 000000000000..3552b83c449e
--- /dev/null
+++ b/dev-haskell/memory/memory-0.14.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: +support_bytestring,+support_deepseq
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="memory and related abstraction stuff"
+HOMEPAGE="https://github.com/vincenthz/hs-memory"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=support_bytestring \
+ --flag=support_deepseq
+}