summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/memory
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/memory')
-rw-r--r--dev-haskell/memory/Manifest1
-rw-r--r--dev-haskell/memory/memory-0.7.ebuild35
-rw-r--r--dev-haskell/memory/metadata.xml19
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/memory/Manifest b/dev-haskell/memory/Manifest
new file mode 100644
index 000000000000..282f05f8ce7c
--- /dev/null
+++ b/dev-haskell/memory/Manifest
@@ -0,0 +1 @@
+DIST memory-0.7.tar.gz 33072 SHA256 e123c8851a0f9bc3d442a462324bb828f6571d0d90fe1c6cb671f8913bd941fa SHA512 5df9d3ff6ab1fad7760a34d22657af255d7ad57019e8b61bd81dbd09b5df6da83d93e667989c10ebea2910a3399be05ef33d298aca0b09764b0e3a855fba15a8 WHIRLPOOL 1fd9dd8ad19181017ca6a9a49fb32ffd2952f1f1a58d6df102d2bbbd1c2a0d2e6aa891f67a712a072c7fb97c37486f4866a388cabc5f427fe590e5eb3ca3e085
diff --git a/dev-haskell/memory/memory-0.7.ebuild b/dev-haskell/memory/memory-0.7.ebuild
new file mode 100644
index 000000000000..2d548db5f1c0
--- /dev/null
+++ b/dev-haskell/memory/memory-0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: +support_bytestring,+support_deepseq
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="memory and related abtraction stuff"
+HOMEPAGE="https://github.com/vincenthz/hs-memory"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=support_bytestring \
+ --flag=support_deepseq
+}
diff --git a/dev-haskell/memory/metadata.xml b/dev-haskell/memory/metadata.xml
new file mode 100644
index 000000000000..6e8c8539217f
--- /dev/null
+++ b/dev-haskell/memory/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Chunk of memory, polymorphic byte array management and manipulation
+
+ * A polymorphic byte array abstraction and function similar to strict ByteString.
+
+ * Different type of byte array abstraction.
+
+ * Raw memory IO operations (memory set, memory copy, ..)
+
+ * Aliasing with endianness support.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-memory</remote-id>
+ </upstream>
+</pkgmetadata>