summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-12 01:36:11 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:26 +0000
commit72220f2a48d106f2dee38ccb0ffe2b5366f10a7e (patch)
tree7af9d9341acb2bb65d90242952fedb6963d1626a /dev-haskell/memory
parentdev-haskell/math-functions: keyword 0.3.3.0 for ~ppc64 (diff)
downloadgentoo-72220f2a48d106f2dee38ccb0ffe2b5366f10a7e.tar.gz
gentoo-72220f2a48d106f2dee38ccb0ffe2b5366f10a7e.tar.bz2
gentoo-72220f2a48d106f2dee38ccb0ffe2b5366f10a7e.zip
dev-haskell/memory: revbump 0.15.0-r1
https://github.com/gentoo-haskell/gentoo-haskell/commit/1e722fe3cee37dba806bc04f3019a7f9535ae723 Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/memory')
-rw-r--r--dev-haskell/memory/Manifest1
-rw-r--r--dev-haskell/memory/memory-0.15.0-r1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/memory/Manifest b/dev-haskell/memory/Manifest
index 10a0607c5c1f..d27e71b51d9c 100644
--- a/dev-haskell/memory/Manifest
+++ b/dev-haskell/memory/Manifest
@@ -1 +1,2 @@
DIST memory-0.15.0.tar.gz 42299 BLAKE2B fd4cebe132ebc824e88907325d6106ab62d01942f5055481f0ff85248ba1a84211e768e49409b02f45ff224a4149338abb771b1dcad38c31175c340e35063fad SHA512 49aabf5fdaddae597df6d8f30a3e07c4d6d70fcc7b9146452a4ad4e81858786041676bc780e2b048fd683cc7c0d799d4579596c14fae940ea57954e9a7ee9129
+DIST memory-81.patch 4543 BLAKE2B 451af2f23cd975403604f40129c5112f1f1e2856ec90c34058cfc6c97b5f84069b6379dd49d9167ad6e25365035470a0c20d76d4d441f26c6ac283b7999cfa44 SHA512 663672478660b0c693ebf41cbbb1ea123857b4f9c10560c4b0faeafea2cab49291daa99eac623a2c0b8541bcff3285a8837f407a61bf3e83084170c63d111a4e
diff --git a/dev-haskell/memory/memory-0.15.0-r1.ebuild b/dev-haskell/memory/memory-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..2c2eb1bfce9d
--- /dev/null
+++ b/dev-haskell/memory/memory-0.15.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+#hackport: flags: +support_foundation,+support_deepseq,+support_bytestring,+support_basement
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="memory and related abstraction stuff"
+HOMEPAGE="https://github.com/vincenthz/hs-memory"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/vincenthz/hs-memory/pull/81.patch -> ${PN}-81.patch"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/basement-0.0.7:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( dev-haskell/foundation )
+"
+
+PATCHES=( "${DISTDIR}/${PN}-81.patch" )
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=support_basement \
+ --flag=support_bytestring \
+ --flag=support_deepseq \
+ --flag=support_foundation
+}