summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 11:37:42 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:02:37 +0100
commit07afea2dd73abb743c4605f0ad39f681a3dc5742 (patch)
tree1c27d7b59317752b3e35fa206e00cf9305b868c0 /dev-haskell/mintty
parentdev-haskell/rio-prettyprint: add package (diff)
downloadgentoo-07afea2dd73abb743c4605f0ad39f681a3dc5742.tar.gz
gentoo-07afea2dd73abb743c4605f0ad39f681a3dc5742.tar.bz2
gentoo-07afea2dd73abb743c4605f0ad39f681a3dc5742.zip
dev-haskell/mintty: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/mintty')
-rw-r--r--dev-haskell/mintty/Manifest1
-rw-r--r--dev-haskell/mintty/metadata.xml27
-rw-r--r--dev-haskell/mintty/mintty-0.1.2.ebuild24
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/mintty/Manifest b/dev-haskell/mintty/Manifest
new file mode 100644
index 000000000000..f7b33075eeee
--- /dev/null
+++ b/dev-haskell/mintty/Manifest
@@ -0,0 +1 @@
+DIST mintty-0.1.2.tar.gz 6945 BLAKE2B 6fe05a5d130c807b8dca29e5c207bff3ce73778ed4ca9e27f2a54c1b28410a7043b8d7f8ad4de7b8c93e555f8577e9644a1d7e86cae0fdba94098d34e3fadfce SHA512 6737851b82bec6977114baa572bdd012ff933a9d1c401857b97183fe341f605cc85618f2d0ac4afe2046cd90ec011d595bb82dea775f65b7e1d73dcf41777667
diff --git a/dev-haskell/mintty/metadata.xml b/dev-haskell/mintty/metadata.xml
new file mode 100644
index 000000000000..dccdf4080195
--- /dev/null
+++ b/dev-haskell/mintty/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ MinTTY is a Windows-specific terminal emulator for the
+ widely used Cygwin and MSYS projects, which provide
+ Unix-like environments for Windows. MinTTY consoles behave
+ differently from native Windows consoles (such as
+ @cmd.exe@ or PowerShell) in many ways, and in some cases,
+ these differences make it necessary to treat MinTTY
+ consoles differently in code.
+
+ The @mintty@ library provides a simple way to detect if
+ your code in running in a MinTTY console on Windows. It
+ exports @isMinTTY@, which does the right thing 90% of the
+ time (by checking if standard error is attached to
+ MinTTY), and it also exports @isMinTTYHandle@ for the
+ other 10% of the time (when you want to check is some
+ arbitrary handle is attached to MinTTY). As you might
+ expect, both of these functions will simply return @False@
+ on any non-Windows operating system.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/mintty/mintty-0.1.2.ebuild b/dev-haskell/mintty/mintty-0.1.2.ebuild
new file mode 100644
index 000000000000..827af5189248
--- /dev/null
+++ b/dev-haskell/mintty/mintty-0.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.6
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A reliable way to detect the presence of a MinTTY console on Windows"
+HOMEPAGE="https://github.com/RyanGlScott/mintty"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"