summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-29 22:17:12 -0400
committerSam James <sam@gentoo.org>2022-07-30 06:58:56 +0100
commit8da95e7ef4b28a0f58f067c0187ad6ec10cbfdbd (patch)
treec6ad749d0d099d06f9128904c280ab1cbe0c4efe /dev-haskell/missingh
parentdev-haskell/regex-compat: keyword 0.95.2.1 for ~ppc64 (diff)
downloadgentoo-8da95e7ef4b28a0f58f067c0187ad6ec10cbfdbd.tar.gz
gentoo-8da95e7ef4b28a0f58f067c0187ad6ec10cbfdbd.tar.bz2
gentoo-8da95e7ef4b28a0f58f067c0187ad6ec10cbfdbd.zip
dev-haskell/missingh: revbump 1.4.3.0-r1
https://github.com/gentoo-haskell/gentoo-haskell/commit/e1c12df51a75b53806fe1f35d95fdc43c8289138 https://github.com/gentoo-haskell/gentoo-haskell/commit/3be430feb168f54686a5018d1017d945221b5f1f Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/missingh')
-rw-r--r--dev-haskell/missingh/metadata.xml18
-rw-r--r--dev-haskell/missingh/missingh-1.4.3.0-r1.ebuild (renamed from dev-haskell/missingh/missingh-1.4.3.0.ebuild)23
2 files changed, 23 insertions, 18 deletions
diff --git a/dev-haskell/missingh/metadata.xml b/dev-haskell/missingh/metadata.xml
index 2139218ddd52..1bea67aa73fb 100644
--- a/dev-haskell/missingh/metadata.xml
+++ b/dev-haskell/missingh/metadata.xml
@@ -1,13 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- </maintainer>
- <use>
- <flag name="network-3">Use network-3</flag>
- </use>
- <upstream>
- <remote-id type="github">jgoerzen/missingh</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ MissingH is a library of all sorts of utility functions for
+ Haskell programmers. It is written in pure Haskell and thus should
+ be extremely portable and easy to use.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-haskell/missingh/missingh-1.4.3.0.ebuild b/dev-haskell/missingh/missingh-1.4.3.0-r1.ebuild
index 102bc03f9c1d..a307a2039f37 100644
--- a/dev-haskell/missingh/missingh-1.4.3.0.ebuild
+++ b/dev-haskell/missingh/missingh-1.4.3.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.4.9999
-#hackport: flags: network--ge-3-0-0:network-3
+#hackport: flags: +network--ge-3-0-0
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -18,8 +18,7 @@ SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="+network-3"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux"
RESTRICT=test # tests are present for removed modules
@@ -28,12 +27,11 @@ RDEPEND=">=dev-haskell/hslogger-1.3.0.0:=[profile?] <dev-haskell/hslogger-1.4:=[
>=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
>=dev-haskell/old-time-1.1:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
>=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
- >=dev-haskell/random-1.0.1.1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ dev-haskell/random
>=dev-haskell/regex-compat-0.95.1:=[profile?] <dev-haskell/regex-compat-0.96:=[profile?]
>=dev-lang/ghc-7.4.1:=
- network-3? ( >=dev-haskell/network-3.0:=[profile?] <dev-haskell/network-3.2:=[profile?]
- >=dev-haskell/network-bsd-2.8.1:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?] )
- !network-3? ( >=dev-haskell/network-2.6.3.1:=[profile?] <dev-haskell/network-2.9:=[profile?] )
+ >=dev-haskell/network-3.0:=[profile?] <dev-haskell/network-3.2:=[profile?]
+ >=dev-haskell/network-bsd-2.8.1:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.12
@@ -43,7 +41,14 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ default
+ cabal_chdeps \
+ 'base >= 4.5.0.0 && < 4.15' 'base >= 4.5.0.0' \
+ 'random >= 1.0.1.1 && < 1.2' 'random'
+}
+
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag network-3 network--ge-3_0_0)
+ --flag=network--ge-3_0_0
}