summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/network/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/network/files')
-rw-r--r--dev-haskell/network/files/network-2.2.0.0-eat-configure-opts.patch17
-rw-r--r--dev-haskell/network/files/network-2.3.0.14-ghc-7.5.patch69
-rw-r--r--dev-haskell/network/files/network-2.4.0.1-fix-ppc64.patch39
3 files changed, 125 insertions, 0 deletions
diff --git a/dev-haskell/network/files/network-2.2.0.0-eat-configure-opts.patch b/dev-haskell/network/files/network-2.2.0.0-eat-configure-opts.patch
new file mode 100644
index 000000000000..49c430da44a7
--- /dev/null
+++ b/dev-haskell/network/files/network-2.2.0.0-eat-configure-opts.patch
@@ -0,0 +1,17 @@
+Make sure ./configure can eat --with-hc and --with-hc-pkg without giving QA
+warnings.
+
+diff -rN -u old-network-2.2.0.0/configure.ac new-network-2.2.0.0/configure.ac
+--- old-network-2.2.0.0/configure.ac 2009-07-21 22:07:20.000000000 +0200
++++ new-network-2.2.0.0/configure.ac 2009-07-21 22:07:20.000000000 +0200
+@@ -14,6 +14,10 @@
+
+ AC_C_CONST
+
++dnl * dummy options to eat --with-hc= and --with-hc-pkg= flags
++AC_ARG_WITH([hc], [(dummy option)], [])
++AC_ARG_WITH([hc-pkg], [(dummy option)], [])
++
+ dnl ** check for specific header (.h) files that we are interested in
+ AC_CHECK_HEADERS([fcntl.h limits.h stdlib.h sys/types.h unistd.h winsock.h])
+ AC_CHECK_HEADERS([arpa/inet.h netdb.h netinet/in.h netinet/tcp.h sys/socket.h sys/uio.h sys/un.h])
diff --git a/dev-haskell/network/files/network-2.3.0.14-ghc-7.5.patch b/dev-haskell/network/files/network-2.3.0.14-ghc-7.5.patch
new file mode 100644
index 000000000000..e6a01539728a
--- /dev/null
+++ b/dev-haskell/network/files/network-2.3.0.14-ghc-7.5.patch
@@ -0,0 +1,69 @@
+--- network-2.3.0.14-orig/network.cabal 2012-06-04 10:25:39.000000000 +1000
++++ network-2.3.0.14/network.cabal 2012-06-27 20:21:38.271566190 +1000
+@@ -39,7 +39,7 @@
+ Network.Socket.ByteString.MsgHdr
+
+ build-depends:
+- base >= 3 && < 4.6,
++ base >= 3 && < 4.7,
+ bytestring < 1.0,
+ parsec >= 2.0 && < 3.2
+
+@@ -62,11 +62,11 @@
+ type: exitcode-stdio-1.0
+
+ build-depends:
+- base < 4.6,
+- bytestring < 0.10,
++ base < 4.7,
++ bytestring < 1.0,
+ HUnit < 1.3,
+ network,
+- test-framework < 0.6,
++ test-framework < 0.7,
+ test-framework-hunit < 0.3
+
+ test-suite uri
+@@ -75,10 +75,10 @@
+ type: exitcode-stdio-1.0
+
+ build-depends:
+- base < 4.6,
++ base < 4.7,
+ HUnit < 1.3,
+ network,
+- test-framework < 0.6,
++ test-framework < 0.7,
+ test-framework-hunit < 0.3
+
+ source-repository head
+--- network-2.3.0.14-orig/Network/BSD.hsc 2012-06-04 10:25:39.000000000 +1000
++++ network-2.3.0.14/Network/BSD.hsc 2012-06-28 18:07:39.287001755 +1000
+@@ -112,7 +112,9 @@
+ import Foreign.Marshal.Array (allocaArray0, peekArray0)
+ import Foreign.Marshal.Utils (with, fromBool)
+ import Data.Typeable
++#if !MIN_VERSION_base(4,6,0)
+ import Prelude hiding (catch)
++#endif
+ import System.IO.Error (ioeSetErrorString, mkIOError)
+ import System.IO.Unsafe (unsafePerformIO)
+
+--- network-2.3.0.14-orig/tests/Simple.hs 2012-06-04 10:25:39.000000000 +1000
++++ network-2.3.0.14/tests/Simple.hs 2012-06-28 18:18:31.176027682 +1000
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE ScopedTypeVariables #-}
++{-# LANGUAGE CPP, ScopedTypeVariables #-}
+ {-# OPTIONS_GHC -fno-warn-unused-do-bind #-}
+
+ module Main where
+@@ -10,7 +10,9 @@
+ import qualified Data.ByteString.Char8 as C
+ import Network.Socket hiding (recv, recvFrom, send, sendTo)
+ import Network.Socket.ByteString
++#if !MIN_VERSION_base(4,6,0)
+ import Prelude hiding (catch)
++#endif
+ import Test.Framework (Test, defaultMain, testGroup)
+ import Test.Framework.Providers.HUnit (testCase)
+ import Test.HUnit (Assertion, (@=?))
diff --git a/dev-haskell/network/files/network-2.4.0.1-fix-ppc64.patch b/dev-haskell/network/files/network-2.4.0.1-fix-ppc64.patch
new file mode 100644
index 000000000000..e891831aeef4
--- /dev/null
+++ b/dev-haskell/network/files/network-2.4.0.1-fix-ppc64.patch
@@ -0,0 +1,39 @@
+commit 6bc6b666ba2a87001a825bd81088062307a51bae
+Author: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sun Jan 13 23:50:21 2013 +0300
+
+ MsgHdr.hsc: fix field 'struct msghdr::msg_namelen' size
+
+ msg_namelen has a 'socklen_t' type on linux (always 32 bits).
+ Using CSize there breaks 64-bit BE platforms.
+
+ testSendManyTo: [Failed]
+ ERROR: sendmsg: invalid argument (Destination address required)
+
+ Caught by testSendManyTo test on ppc64:
+
+ Gentoo-bug: http://bugs.gentoo.org/436640
+ Reported-by: Anthony Basile <blueness@gentoo.org>
+ Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+
+diff --git a/Network/Socket/ByteString/MsgHdr.hsc b/Network/Socket/ByteString/MsgHdr.hsc
+index 24d7eb0..227e5ee 100644
+--- a/Network/Socket/ByteString/MsgHdr.hsc
++++ b/Network/Socket/ByteString/MsgHdr.hsc
+@@ -8,6 +8,7 @@ module Network.Socket.ByteString.MsgHdr
+ #include <sys/types.h>
+ #include <sys/socket.h>
+
++import Data.Word -- for used '#type's
+ import Foreign.C.Types (CInt, CSize)
+ import Foreign.Ptr (Ptr)
+ import Foreign.Storable (Storable(..))
+@@ -20,7 +21,7 @@ import Network.Socket.ByteString.IOVec (IOVec)
+ -- don't exist on OpenSolaris.
+ data MsgHdr = MsgHdr
+ { msgName :: Ptr SockAddr
+- , msgNameLen :: CSize
++ , msgNameLen :: (#type socklen_t) {- 32 bits even on amd64 and ppc64 -}
+ , msgIov :: Ptr IOVec
+ , msgIovLen :: CSize
+ }