summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/options
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/options')
-rw-r--r--dev-haskell/options/Manifest3
-rw-r--r--dev-haskell/options/files/options-1.2.1-ghc-7.10.patch24
-rw-r--r--dev-haskell/options/metadata.xml60
-rw-r--r--dev-haskell/options/options-1.2-r1.ebuild36
-rw-r--r--dev-haskell/options/options-1.2.1.1.ebuild29
-rw-r--r--dev-haskell/options/options-1.2.1.ebuild39
6 files changed, 191 insertions, 0 deletions
diff --git a/dev-haskell/options/Manifest b/dev-haskell/options/Manifest
new file mode 100644
index 000000000000..b671d0769606
--- /dev/null
+++ b/dev-haskell/options/Manifest
@@ -0,0 +1,3 @@
+DIST options-1.2.1.1.tar.gz 25327 SHA256 283eea9ae2c539830c6c65f5c03fb00626cfd1274da0526c285c146fc3065a62 SHA512 615a3767b74ca0ba2eae993f6e475963df2a0933f1e6c9bbfe35144c4dc6018af276144b2ec1b608b695dc7fca904784ebc63cd58a432f966588846cb36f94ea WHIRLPOOL b8a2a6f64d573ad355e82bbd3dbb7fa1c234f3a29ad26b5e3c24f6feaed9107cba29b7fa0ce54dff7e7054bf96f71f5cbe26a3410489c98eaf15286e1d25caf9
+DIST options-1.2.1.tar.gz 25252 SHA256 75f84bc3d369f534daef5b9f7db9f581f38974d7ae7bd389b754d30f59bc32f9 SHA512 fedc10b4e8d1dca4a93e90cbc2f37f0570af6657a4ba1492b2da9267a38ba8533b1c599dd36eb2660d016374cc34857a57785fd5c305bad2e5c1d23bbe559ab7 WHIRLPOOL aa62c8c1eba2bb1a90f1966687f7f9d8f34fc4ab2fd276381019a88597c99f86ed48ebe555059b57207be4a4cc5e86e94a501e0c0c9489e21d782c472d4d1b85
+DIST options-1.2.tar.gz 25214 SHA256 7d9353b93ff22a9a20c088a6895d08b02266e1a61e5c7192711c14881a9f1993 SHA512 9c7cfcfbf3e1e487bc80a3ea68ba484b22b7adecf65af5e5f3d3cd9ebcabf952286cf1b29d6e1ef6654eed49aeb70a2936bc977f8c3665bd7ab59340cf2f2f18 WHIRLPOOL 1ef4d4c61464379d35cc8445c331387247d3dd67122b0d8a7b9030a70c67c3e44e41272aef9fa6b792addb2d08dde55dd079a581b4f1f5ffd5f63ffe3054db53
diff --git a/dev-haskell/options/files/options-1.2.1-ghc-7.10.patch b/dev-haskell/options/files/options-1.2.1-ghc-7.10.patch
new file mode 100644
index 000000000000..9578c926528e
--- /dev/null
+++ b/dev-haskell/options/files/options-1.2.1-ghc-7.10.patch
@@ -0,0 +1,24 @@
+--- options-1.2.1-orig/lib/Options/Tokenize.hs 2014-12-14 16:34:53.000000000 +1100
++++ options-1.2.1/lib/Options/Tokenize.hs 2015-01-02 00:14:05.390013340 +1100
+@@ -11,6 +11,7 @@
+ , tokenize
+ ) where
+
++import Control.Applicative
+ import Control.Monad.Error hiding (throwError)
+ import qualified Control.Monad.Error
+ import Control.Monad.State
+@@ -53,6 +54,13 @@
+
+ newtype Tok a = Tok { unTok :: ErrorT String (StateT TokState Identity) a }
+
++instance Functor Tok where
++ fmap = liftM
++
++instance Applicative Tok where
++ pure = return
++ (<*>) = ap
++
+ instance Monad Tok where
+ return = Tok . return
+ m >>= f = Tok (unTok m >>= unTok . f)
diff --git a/dev-haskell/options/metadata.xml b/dev-haskell/options/metadata.xml
new file mode 100644
index 000000000000..51a1b75d2a74
--- /dev/null
+++ b/dev-haskell/options/metadata.xml
@@ -0,0 +1,60 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The @options@ package lets library and application developers easily work
+ with command-line options.
+
+ The following example is a full program that can accept two options,
+ @--message@ and @--quiet@:
+
+ @
+ import Control.Applicative
+ import Options
+
+ data MainOptions = MainOptions
+ &amp;#x20; &amp;#x7b; optMessage :: String
+ &amp;#x20; , optQuiet :: Bool
+ &amp;#x20; &amp;#x7d;
+
+ instance &#39;Options&#39; MainOptions where
+ &amp;#x20; defineOptions = pure MainOptions
+ &amp;#x20; \&lt;*\&gt; simpleOption \&quot;message\&quot; \&quot;Hello world!\&quot;
+ &amp;#x20; \&quot;A message to show the user.\&quot;
+ &amp;#x20; \&lt;*\&gt; simpleOption \&quot;quiet\&quot; False
+ &amp;#x20; \&quot;Whether to be quiet.\&quot;
+
+ main :: IO ()
+ main = runCommand $ \\opts args -&gt; do
+ &amp;#x20; if optQuiet opts
+ &amp;#x20; then return ()
+ &amp;#x20; else putStrLn (optMessage opts)
+ @
+
+ &gt;$ ./hello
+ &gt;Hello world!
+ &gt;$ ./hello --message=&#39;ciao mondo&#39;
+ &gt;ciao mondo
+ &gt;$ ./hello --quiet
+ &gt;$
+
+ In addition, this library will automatically create documentation options
+ such as @--help@ and @--help-all@:
+
+ &gt;$ ./hello --help
+ &gt;Help Options:
+ &gt; -h, --help
+ &gt; Show option summary.
+ &gt; --help-all
+ &gt; Show all help options.
+ &gt;
+ &gt;Application Options:
+ &gt; --message :: text
+ &gt; A message to show the user.
+ &gt; default: &quot;Hello world!&quot;
+ &gt; --quiet :: bool
+ &gt; Whether to be quiet.
+ &gt; default: false
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/options/options-1.2-r1.ebuild b/dev-haskell/options/options-1.2-r1.ebuild
new file mode 100644
index 000000000000..900e3b513290
--- /dev/null
+++ b/dev-haskell/options/options-1.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A powerful and easy-to-use command-line option parser"
+HOMEPAGE="https://john-millikin.com/software/haskell-options/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/monads-tf-0.1:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/chell-0.3.1 <dev-haskell/chell-0.5
+ >=dev-haskell/chell-quickcheck-0.2 <dev-haskell/chell-quickcheck-0.3
+ >=dev-haskell/monads-tf-0.1
+ >=dev-haskell/transformers-0.2 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'chell >= 0.3.1 && < 0.4' 'chell >= 0.3.1 && < 0.5'
+}
diff --git a/dev-haskell/options/options-1.2.1.1.ebuild b/dev-haskell/options/options-1.2.1.1.ebuild
new file mode 100644
index 000000000000..f2c1f7d679e6
--- /dev/null
+++ b/dev-haskell/options/options-1.2.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A powerful and easy-to-use command-line option parser"
+HOMEPAGE="https://john-millikin.com/software/haskell-options/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/monads-tf-0.1:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/chell-0.4 <dev-haskell/chell-0.5
+ >=dev-haskell/chell-quickcheck-0.2 <dev-haskell/chell-quickcheck-0.3 )
+"
diff --git a/dev-haskell/options/options-1.2.1.ebuild b/dev-haskell/options/options-1.2.1.ebuild
new file mode 100644
index 000000000000..b672c9cde5e5
--- /dev/null
+++ b/dev-haskell/options/options-1.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit base haskell-cabal
+
+DESCRIPTION="A powerful and easy-to-use command-line option parser"
+HOMEPAGE="https://john-millikin.com/software/haskell-options/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RESTRICT=test # needs old chell
+
+RDEPEND=">=dev-haskell/monads-tf-0.1:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/chell-0.3.1 <dev-haskell/chell-0.5
+ >=dev-haskell/chell-quickcheck-0.2 <dev-haskell/chell-quickcheck-0.3 )
+"
+
+PATCHES=("${FILESDIR}/${PN}-1.2.1-ghc-7.10.patch")
+
+src_prepare() {
+ base_src_prepare
+ cabal_chdeps \
+ 'chell >= 0.3.1 && < 0.4' 'chell >= 0.3.1 && < 0.5'
+}