summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-09-12 22:48:47 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-12 22:57:21 +0100
commit0c33e4b0ef40a57a29ef64aaa494b9f8c2d81dc2 (patch)
treede7043d22c8b1337e5c817943d22d34eb04f3545 /dev-haskell/pcre-light
parentdev-haskell/patience: drop old (diff)
downloadgentoo-0c33e4b0ef40a57a29ef64aaa494b9f8c2d81dc2.tar.gz
gentoo-0c33e4b0ef40a57a29ef64aaa494b9f8c2d81dc2.tar.bz2
gentoo-0c33e4b0ef40a57a29ef64aaa494b9f8c2d81dc2.zip
dev-haskell/pcre-light: drop old
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/pcre-light')
-rw-r--r--dev-haskell/pcre-light/Manifest2
-rw-r--r--dev-haskell/pcre-light/files/pcre-light-0.4-ghc-7.7.patch39
-rw-r--r--dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild27
-rw-r--r--dev-haskell/pcre-light/pcre-light-0.4.0.4.ebuild26
4 files changed, 0 insertions, 94 deletions
diff --git a/dev-haskell/pcre-light/Manifest b/dev-haskell/pcre-light/Manifest
index 98343960ee1d..34bd1df2bb4d 100644
--- a/dev-haskell/pcre-light/Manifest
+++ b/dev-haskell/pcre-light/Manifest
@@ -1,3 +1 @@
-DIST pcre-light-0.4.0.4.tar.gz 15065 BLAKE2B 5ce576bc77e61265326bda0109ce5b8692f06401630400a5f3e8fc94afe3cf7334c0800774bc5acae251a78d4ffe488a3c3435c67d467f75c9ff58c2d8a33996 SHA512 ca5f52a8737b2785b4d3eb7c1463233dc579cf10bdb620397f842d4bddafbe636b992f725f85086e5916f2def163d5d25661acd24a358421e2f7f859a2f876f0
DIST pcre-light-0.4.1.0.tar.gz 28908 BLAKE2B 10b24f61d6d4a8669464d2a003fcf3a677fc34f7e0369106d3986e18c97c0cb6509620ac7a545dc0e3246c76e5221ae30e32565c02b5fbdc58b6c2524265f314 SHA512 491d9581e4c29d1a5a3b161210b83abbc135c2d0ee4018481f4101f91c95e93d7acf0764cb464a9ffe84bed9bf8fb400f4c68441ae1be03c0aa182a9be26dc39
-DIST pcre-light-0.4.tar.gz 28943 BLAKE2B 3458990cddf6361c7b67fcc66c8abfb900e6e1efd93c1eb5b8ab9d46337911e5122dc20d5ba9a1cb28a9cafbab64d06bb15e79361d64e06bb4f6c19674fe40ad SHA512 1cbb37743018e0199d3c23f5cda34a41514ecc375650f2a79935c16b12b4411e5ce1d7fc84b29fbb41458a2493998471cbefc54adbf848d59877c6be4d34b6aa
diff --git a/dev-haskell/pcre-light/files/pcre-light-0.4-ghc-7.7.patch b/dev-haskell/pcre-light/files/pcre-light-0.4-ghc-7.7.patch
deleted file mode 100644
index 2b4181929f60..000000000000
--- a/dev-haskell/pcre-light/files/pcre-light-0.4-ghc-7.7.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/Text/Regex/PCRE/Light.hs b/Text/Regex/PCRE/Light.hs
-index 80c28a0..7fc9581 100644
---- a/Text/Regex/PCRE/Light.hs
-+++ b/Text/Regex/PCRE/Light.hs
-@@ -77,6 +77,7 @@ import qualified Data.ByteString as S
- #if __GLASGOW_HASKELL__ >= 608
- import qualified Data.ByteString.Internal as S
- import qualified Data.ByteString.Unsafe as S
-+import qualified System.IO.Unsafe as U
- #else
- import qualified Data.ByteString.Base as S
- #endif
-@@ -193,7 +194,7 @@ compile s o = case compileM s o of
- -- > Left "nothing to repeat"
- --
- compileM :: S.ByteString -> [PCREOption] -> Either String Regex
--compileM str os = unsafePerformIO $
-+compileM str os = U.unsafePerformIO $
- S.useAsCString str $ \pattern -> do
- alloca $ \errptr -> do
- alloca $ \erroffset -> do
-@@ -263,7 +264,7 @@ compileM str os = unsafePerformIO $
- -- is returned.
- --
- match :: Regex -> S.ByteString -> [PCREExecOption] -> Maybe [S.ByteString]
--match (Regex pcre_fp _) subject os = unsafePerformIO $ do
-+match (Regex pcre_fp _) subject os = U.unsafePerformIO $ do
- withForeignPtr pcre_fp $ \pcre_ptr -> do
- n_capt <- captureCount' pcre_ptr
-
-@@ -324,7 +325,7 @@ match (Regex pcre_fp _) subject os = unsafePerformIO $ do
-
-
- captureCount :: Regex -> Int
--captureCount (Regex pcre_fp _) = unsafePerformIO $ do
-+captureCount (Regex pcre_fp _) = U.unsafePerformIO $ do
- withForeignPtr pcre_fp $ \pcre_ptr -> do
- captureCount' pcre_ptr
-
diff --git a/dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild b/dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild
deleted file mode 100644
index 1b938d18b1d4..000000000000
--- a/dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.4.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit base haskell-cabal
-
-DESCRIPTION="Portable regex library for Perl 5 compatible regular expressions"
-HOMEPAGE="http://code.haskell.org/~dons/code/pcre-light"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE=""
-
-RDEPEND=">=dev-lang/ghc-6.10.4:=
- dev-libs/libpcre
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6.0.3
-"
-
-PATCHES=("${FILESDIR}"/${P}-ghc-7.7.patch)
diff --git a/dev-haskell/pcre-light/pcre-light-0.4.0.4.ebuild b/dev-haskell/pcre-light/pcre-light-0.4.0.4.ebuild
deleted file mode 100644
index c24b8ef991ce..000000000000
--- a/dev-haskell/pcre-light/pcre-light-0.4.0.4.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Portable regex library for Perl 5 compatible regular expressions"
-HOMEPAGE="https://github.com/Daniel-Diaz/pcre-light"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE=""
-
-RDEPEND=">=dev-lang/ghc-7.4.1:=
- dev-libs/libpcre
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.2.0
- virtual/pkgconfig
-"