summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/regex-compat-tdfa
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/regex-compat-tdfa')
-rw-r--r--dev-haskell/regex-compat-tdfa/Manifest1
-rw-r--r--dev-haskell/regex-compat-tdfa/metadata.xml18
-rw-r--r--dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild33
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/regex-compat-tdfa/Manifest b/dev-haskell/regex-compat-tdfa/Manifest
new file mode 100644
index 000000000000..9f4ba553667c
--- /dev/null
+++ b/dev-haskell/regex-compat-tdfa/Manifest
@@ -0,0 +1 @@
+DIST regex-compat-tdfa-0.95.1.4.tar.gz 4146 SHA256 4fa38ed24ae390eeffe6eef04bbe632d7ecd02b9123729e976e7420f927520dd SHA512 7e387a7713ff8e43cfce4262b1288b85f8b60729162a842186bf6a7e1078dfb9e26013087ff7e9bcf81521f8c352926873bb280b9df57b016aef2ca4ce70aa14 WHIRLPOOL 37f6c1b74d412ec59d37a88500adef6b88c9a7ed39a433e1cfc0c607cd7af5d77526d2bdf037bb65757d2a232ff96ed3bc165c4492862f5b3f751317c09973ab
diff --git a/dev-haskell/regex-compat-tdfa/metadata.xml b/dev-haskell/regex-compat-tdfa/metadata.xml
new file mode 100644
index 000000000000..b74f210b6c3b
--- /dev/null
+++ b/dev-haskell/regex-compat-tdfa/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <use>
+ <flag name="newbase">Use base-4.0 or newer.</flag>
+ <flag name="splitbase">Use the new smaller, split-up base package.</flag>
+ </use>
+ <longdescription>
+ One module layer over regex-tdfa to replace Text.Regex.
+
+ regex-compat can&#39;t use Unicode characters correctly because
+ of using regex-posix. This is not good for Unicode users.
+
+ I modified regex-compat to use regex-tdfa for solving today&#39;s
+ problem.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild b/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
new file mode 100644
index 000000000000..d8127f9e0c3e
--- /dev/null
+++ b/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Unicode Support version of Text.Regex, using regex-tdfa"
+HOMEPAGE="http://hub.darcs.net/shelarcy/regex-compat-tdfa"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+newbase +splitbase"
+
+RDEPEND=">=dev-haskell/regex-base-0.93:=[profile?]
+ >=dev-haskell/regex-tdfa-1.1.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag newbase newbase) \
+ $(cabal_flag splitbase splitbase)
+}