summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 10:34:55 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 08:59:18 +0100
commitf480dc48f23f08ad6941a270f437571223c88d9c (patch)
treee306bd7dcd4f385ee163aa3b015e6c54c753faaf /dev-haskell/resolv
parentdev-haskell/text: bump up to 1.2.4.0 (diff)
downloadgentoo-f480dc48f23f08ad6941a270f437571223c88d9c.tar.gz
gentoo-f480dc48f23f08ad6941a270f437571223c88d9c.tar.bz2
gentoo-f480dc48f23f08ad6941a270f437571223c88d9c.zip
dev-haskell/resolv: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/resolv')
-rw-r--r--dev-haskell/resolv/Manifest1
-rw-r--r--dev-haskell/resolv/metadata.xml31
-rw-r--r--dev-haskell/resolv/resolv-0.1.2.0.ebuild27
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-haskell/resolv/Manifest b/dev-haskell/resolv/Manifest
new file mode 100644
index 000000000000..0fda8cf1bcc1
--- /dev/null
+++ b/dev-haskell/resolv/Manifest
@@ -0,0 +1 @@
+DIST resolv-0.1.2.0.tar.gz 156710 BLAKE2B dbad867d764db2075724a06d9f9dfa8dff882683849883cb9ade6d0654fefe9f024445cd137dca516b80cc2982544b794de7c82fd5d5f482a3891422a699f2c9 SHA512 fae2d0717a109b0d6cc19c51c773bc68c64c0048b9d930528cf5622ee270ebaddec180c1d444542e8eb036262611f5b88deadeea223fb2ef2b15b41369a2376e
diff --git a/dev-haskell/resolv/metadata.xml b/dev-haskell/resolv/metadata.xml
new file mode 100644
index 000000000000..9990695ff28a
--- /dev/null
+++ b/dev-haskell/resolv/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package implements an API for accessing
+ the [Domain Name Service (DNS)](https://tools.ietf.org/html/rfc1035)
+ resolver service via the standard @libresolv@ system library (whose
+ API is often available directly via the standard @libc@ C library) on
+ Unix systems.
+
+ This package also includes support for decoding message record types
+ as defined in the following RFCs:
+
+ - [RFC 1035](https://tools.ietf.org/html/rfc1035): Domain Names - Implementation And Specification
+ - [RFC 1183](https://tools.ietf.org/html/rfc1183): New DNS RR Definitions
+ - [RFC 2782](https://tools.ietf.org/html/rfc2782): A DNS RR for specifying the location of services (DNS SRV)
+ - [RFC 2915](https://tools.ietf.org/html/rfc2915): The Naming Authority Pointer (NAPTR) DNS Resource Record
+ - [RFC 3596](https://tools.ietf.org/html/rfc3596): DNS Extensions to Support IP Version 6
+ - [RFC 4034](https://tools.ietf.org/html/rfc4034): Resource Records for the DNS Security Extensions
+ - [RFC 4255](https://tools.ietf.org/html/rfc4255): Using DNS to Securely Publish Secure Shell (SSH) Key Fingerprints
+ - [RFC 4408](https://tools.ietf.org/html/rfc4408): Sender Policy Framework (SPF) for Authorizing Use of Domains in E-Mail, Version 1
+ - [RFC 5155](https://tools.ietf.org/html/rfc5155): DNS Security (DNSSEC) Hashed Authenticated Denial of Existence
+ - [RFC 6844](https://tools.ietf.org/html/rfc6844): DNS Certification Authority Authorization (CAA) Resource Record
+ - [RFC 6891](https://tools.ietf.org/html/rfc6891): Extension Mechanisms for DNS (EDNS(0))
+ - [RFC 7553](https://tools.ietf.org/html/rfc7553): The Uniform Resource Identifier (URI) DNS Resource Record
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/resolv/resolv-0.1.2.0.ebuild b/dev-haskell/resolv/resolv-0.1.2.0.ebuild
new file mode 100644
index 000000000000..f488bd337f9f
--- /dev/null
+++ b/dev-haskell/resolv/resolv-0.1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Broken test-suite: needs a port to new srcloc
+inherit haskell-cabal
+
+DESCRIPTION="Domain Name Service (DNS) lookup via the libresolv standard library routines"
+HOMEPAGE="http://hackage.haskell.org/package/resolv"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # fails to build test suite
+
+RDEPEND=">=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2
+"