summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-05-28 13:38:35 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-05-28 18:52:52 +0100
commita6464b3f66ddace53dad0d7688a8773c9436d7da (patch)
treef08d5c8d54f2cb4cbcee57eed6a76af0d58c0525 /dev-haskell/retry
parentdev-haskell/text-metrics: new package, a depend of dev-haskell/stack (diff)
downloadgentoo-a6464b3f66ddace53dad0d7688a8773c9436d7da.tar.gz
gentoo-a6464b3f66ddace53dad0d7688a8773c9436d7da.tar.bz2
gentoo-a6464b3f66ddace53dad0d7688a8773c9436d7da.zip
dev-haskell/retry: new package, a depend of dev-haskell/stack
Retry combinators for monadic actions that may fail Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-haskell/retry')
-rw-r--r--dev-haskell/retry/Manifest1
-rw-r--r--dev-haskell/retry/metadata.xml20
-rw-r--r--dev-haskell/retry/retry-0.7.4.2.ebuild32
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-haskell/retry/Manifest b/dev-haskell/retry/Manifest
new file mode 100644
index 000000000000..0da330013e1d
--- /dev/null
+++ b/dev-haskell/retry/Manifest
@@ -0,0 +1 @@
+DIST retry-0.7.4.2.tar.gz 9721 SHA256 521b392570b37b17ac8aaea2586a0a16a578f56b9cd0bbf69813b35f7ed2b47c SHA512 5caeb55225759eae466dc0b0a78ff2538380fda75fbd52758639c12c20e3194d2b272fb9286fbffaf70366418654f2e46088954921a9840720b590598314ba2b WHIRLPOOL 6d257f892933740b803118af4ff78555ce56d8f344201174a3bf6b52a309843204bd5c4ef9502c1d9a2d4d783d25f87443ed64adcaba5eee371e3c10ed26e60a
diff --git a/dev-haskell/retry/metadata.xml b/dev-haskell/retry/metadata.xml
new file mode 100644
index 000000000000..8df6740dd53a
--- /dev/null
+++ b/dev-haskell/retry/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package exposes combinators that can wrap arbitrary
+ monadic actions. They run the action and potentially retry
+ running it with some configurable delay for a configurable
+ number of times.
+ The purpose is to make it easier to work with IO and
+ especially network IO actions that often experience temporary
+ failure and warrant retrying of the original action. For
+ example, a database query may time out for a while, in which
+ case we should hang back for a bit and retry the query instead
+ of simply raising an exception.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/retry/retry-0.7.4.2.ebuild b/dev-haskell/retry/retry-0.7.4.2.ebuild
new file mode 100644
index 000000000000..b497f43dc689
--- /dev/null
+++ b/dev-haskell/retry/retry-0.7.4.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Retry combinators for monadic actions that may fail"
+HOMEPAGE="https://github.com/Soostone/retry"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/exceptions-0.5:=[profile?] <dev-haskell/exceptions-0.9:=[profile?]
+ >=dev-haskell/random-1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hspec-1.9
+ >=dev-haskell/hunit-1.2.5.2 <dev-haskell/hunit-1.6
+ dev-haskell/mtl
+ >=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.10
+ dev-haskell/stm )
+"