summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/safesemaphore
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/safesemaphore')
-rw-r--r--dev-haskell/safesemaphore/Manifest2
-rw-r--r--dev-haskell/safesemaphore/metadata.xml13
-rw-r--r--dev-haskell/safesemaphore/safesemaphore-0.10.1.ebuild32
-rw-r--r--dev-haskell/safesemaphore/safesemaphore-0.9.0.ebuild31
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-haskell/safesemaphore/Manifest b/dev-haskell/safesemaphore/Manifest
new file mode 100644
index 000000000000..64fb6afd2ffb
--- /dev/null
+++ b/dev-haskell/safesemaphore/Manifest
@@ -0,0 +1,2 @@
+DIST SafeSemaphore-0.10.1.tar.gz 24007 SHA256 21e5b737a378cae9e1faf85cab015316d4c84d4b37e6d9d202111cef8c4cef66 SHA512 877731622e1942f45fcc43e2ed8ba7ddfa2c1f4a7ea4f36cdf425a98acc9c2f54c742d98a7d1bb457ff122f20a5af399ac776bff7403b892353f812e42007250 WHIRLPOOL 63d4ad889fedb99dd491d5566c6e959b5ba0fb4ca89197482603ff2125fbd9f5166856ba08d37190c63dfebe6d9e9ebc353b919618633936f61d27b242af2d27
+DIST SafeSemaphore-0.9.0.tar.gz 23817 SHA256 e43f805c567a6bcc155cd4ff2b528199e3b22ef9bacd724ccc95231e190343f5 SHA512 a2bb152c8a3d221d75041ee4174cbae1068f8be43388ec1eb1345939f69a06aae34be57299e6713a2ac3d1e81853afda5d29a4ecef198680435dc5a0b23fab86 WHIRLPOOL e4cd6489041937e7e922e98a803867cacfaa097e8fe55a4d18616d57db3546b5f7e40ab186bbd54f2c221bae1a7e938854c46dddcc5a786e31ea1817425601d7
diff --git a/dev-haskell/safesemaphore/metadata.xml b/dev-haskell/safesemaphore/metadata.xml
new file mode 100644
index 000000000000..b169f830d5b5
--- /dev/null
+++ b/dev-haskell/safesemaphore/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This provides a much safer semaphore than the QSem, QSemN, SampleVar in base.
+ Those base modules are not exception safe and can be broken by killThread.
+ See &lt;https://github.com/ChrisKuklewicz/SafeSemaphore&gt; for more details.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ChrisKuklewicz/SafeSemaphore</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/safesemaphore/safesemaphore-0.10.1.ebuild b/dev-haskell/safesemaphore/safesemaphore-0.10.1.ebuild
new file mode 100644
index 000000000000..6552a13cdd69
--- /dev/null
+++ b/dev-haskell/safesemaphore/safesemaphore-0.10.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="SafeSemaphore"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Much safer replacement for QSemN, QSem, and SampleVar"
+HOMEPAGE="https://github.com/ChrisKuklewicz/SafeSemaphore"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND="dev-haskell/stm:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit )
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/safesemaphore/safesemaphore-0.9.0.ebuild b/dev-haskell/safesemaphore/safesemaphore-0.9.0.ebuild
new file mode 100644
index 000000000000..acaa8ce46c5a
--- /dev/null
+++ b/dev-haskell/safesemaphore/safesemaphore-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="SafeSemaphore"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Much safer replacement for QSemN, QSem, and SampleVar"
+HOMEPAGE="https://github.com/ChrisKuklewicz/SafeSemaphore"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND="dev-haskell/stm:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ test? ( dev-haskell/hunit
+ )
+ >=dev-haskell/cabal-1.8"
+
+S="${WORKDIR}/${MY_P}"