summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-23 13:06:16 +1000
committerSam James <sam@gentoo.org>2022-07-23 05:07:55 +0100
commit4b1fc00f2515416c2fad9fc9a93c88aed3c2fdad (patch)
treece8b7bc38577a56cfa62ab4e35b466b878acacfe /dev-haskell/scientific
parentdev-haskell/primitive: drop 0.7.1.0, 0.7.2.0 (diff)
downloadgentoo-4b1fc00f2515416c2fad9fc9a93c88aed3c2fdad.tar.gz
gentoo-4b1fc00f2515416c2fad9fc9a93c88aed3c2fdad.tar.bz2
gentoo-4b1fc00f2515416c2fad9fc9a93c88aed3c2fdad.zip
dev-haskell/scientific: update EAPI 7 -> 8
Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/scientific')
-rw-r--r--dev-haskell/scientific/Manifest2
-rw-r--r--dev-haskell/scientific/scientific-0.3.7.0-r1.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/scientific/Manifest b/dev-haskell/scientific/Manifest
index a8fa4b963ef1..dcf16561e01f 100644
--- a/dev-haskell/scientific/Manifest
+++ b/dev-haskell/scientific/Manifest
@@ -1 +1,3 @@
DIST scientific-0.3.6.2.tar.gz 23510 BLAKE2B 096cd305cdbc4856f48e81de5387b229c4f23fdbfc641243ffa56a74422ec7b224fb2979f22cbdcf747d56c6073ce74ff6ca773093570a8d0a774e2b33d26697 SHA512 47a74524c8fb25d381adf868d823a6b6772f3f69b0b3cf9f9de015a03bc941857ef3fca1b4f8cbf23e998164e71a914e167221e753c6f32dc8644047d1ef57ee
+DIST scientific-0.3.7.0-r1.cabal 4826 BLAKE2B 5c97f879ac7fe64e6584283bd65539aba51a66844bdb19926c163117d36ffc7412434a7191657f4d0f53904299be4893486da489fceba2bfbaa3b6ab8622184e SHA512 e4f9a79dfc05bf9619df070ce9553322bcbf36d81c649ec25afc3ea148fba0eed89ea9e4725942da664109ba3468e383433e4afc9a93d903a17eb50735246832
+DIST scientific-0.3.7.0.tar.gz 24723 BLAKE2B b50d995f6b46d37011823cdd096b1166244c1ab453db490da61eefcf0913f28b9a0b70798aa4ec3c29e6b836d473800b556b6ff062e1e2bee6a25174cd18d52d SHA512 dbd13060a6d1d101138715b4106382a78d115cff247859cb6f83aca3cdb6f6caf8a2c52d7ae99be64845c5e4a7959940bbf31df6265b15079c236f193b087865
diff --git a/dev-haskell/scientific/scientific-0.3.7.0-r1.ebuild b/dev-haskell/scientific/scientific-0.3.7.0-r1.ebuild
new file mode 100644
index 000000000000..d718be487825
--- /dev/null
+++ b/dev-haskell/scientific/scientific-0.3.7.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: -integer-simple
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite
+CABAL_HACKAGE_REVISION="2"
+inherit haskell-cabal
+RESTRICT="test" # circular dependencies
+
+DESCRIPTION="Numbers represented using scientific notation"
+HOMEPAGE="https://github.com/basvandijk/scientific"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/integer-logarithms-1.0.3.1:=[profile?] <dev-haskell/integer-logarithms-1.1:=[profile?]
+ >=dev-haskell/primitive-0.7.1.0:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1"
+# test? ( >=dev-haskell/quickcheck-2.14.2
+# >=dev-haskell/smallcheck-1.0
+# >=dev-haskell/tasty-1.4.0.1
+# >=dev-haskell/tasty-hunit-0.8
+# >=dev-haskell/tasty-quickcheck-0.8
+# >=dev-haskell/tasty-smallcheck-0.2 )
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-integer-simple
+}