summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-31 06:49:08 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:03:17 +0100
commit1556484351ce46d04c68b58cd35a8843ee62c2aa (patch)
treee3a80181f3a1cd05a526ed812c5c1c3085f1a808 /dev-haskell/uuid-types
parentdev-haskell/lens: bump up to 4.19.1 (diff)
downloadgentoo-1556484351ce46d04c68b58cd35a8843ee62c2aa.tar.gz
gentoo-1556484351ce46d04c68b58cd35a8843ee62c2aa.tar.bz2
gentoo-1556484351ce46d04c68b58cd35a8843ee62c2aa.zip
dev-haskell/uuid-types: loosen dependency upper bounds
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/uuid-types')
-rw-r--r--dev-haskell/uuid-types/uuid-types-1.0.3-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/uuid-types/uuid-types-1.0.3-r1.ebuild b/dev-haskell/uuid-types/uuid-types-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..4cae53fd3942
--- /dev/null
+++ b/dev-haskell/uuid-types/uuid-types-1.0.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Type definitions for Universally Unique Identifiers"
+HOMEPAGE="https://github.com/aslatter/uuid"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.9:=[profile?]
+ >=dev-haskell/random-1.0.1:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/text-1:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ >=dev-haskell/hashable-1.1.1.0:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/tasty-0.10
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >=2.4 && < 2.9' 'QuickCheck >=2.4' \
+ 'HUnit >=1.2 && < 1.4' 'HUnit >=1.2' \
+ 'tasty >= 0.10 && < 0.12' 'tasty >= 0.10' \
+ 'tasty-hunit == 0.9.*' 'tasty-hunit >= 0.9' \
+ 'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8' \
+ 'random >= 1.0.1 && < 1.2' 'random >= 1.0.1'
+}