summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/void
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/void')
-rw-r--r--dev-haskell/void/Manifest3
-rw-r--r--dev-haskell/void/metadata.xml14
-rw-r--r--dev-haskell/void/void-0.6.1.ebuild30
-rw-r--r--dev-haskell/void/void-0.6.ebuild30
-rw-r--r--dev-haskell/void/void-0.7.ebuild32
5 files changed, 109 insertions, 0 deletions
diff --git a/dev-haskell/void/Manifest b/dev-haskell/void/Manifest
new file mode 100644
index 000000000000..bd57d1cde9bc
--- /dev/null
+++ b/dev-haskell/void/Manifest
@@ -0,0 +1,3 @@
+DIST void-0.6.1.tar.gz 3807 SHA256 82ec2a7edf3fa52eba2ed4821306859a75186e6df2a564943e9f9d758205ea26 SHA512 9158e201547b43e97d13112d87ab27b7dddff90fff11727c880bbd03e50faf2755ff27c03710e7bd634325a2c31f07e70dae61e62d925fa1f31b0b66e3927c48 WHIRLPOOL cc0baf77fe42c7f4c9c15e3513d573d5e0107bccb0b95facaae8c9b65f7af78f51d02d5ccdafe98bdbdba68e8632afe56f9113b4359db5a72e8b125928385376
+DIST void-0.6.tar.gz 3795 SHA256 3668a66ec838465c78b1fe4c6fff0080aeed5b232e4854894a4d5c868f922d3c SHA512 cba9dd795a0544db307f68d63615857a4024adc80fed164adccc5d10fa09af64ecda899535ebbe32c987028235e0cf1f88834a0b7066dce401045a0e7facd68b WHIRLPOOL 4ddab2af42b4cdd6ff6ab70c8e9ec7a51b0ab49999a46d1c02c3405f55d787389ea89e124bae097013d122713b1b4ef15cb1499c04c3e8800fb1dc11d635ba54
+DIST void-0.7.tar.gz 3900 SHA256 981b85d19bb51c1ac60103b184b86061621e0b016d4db24dd965751b2bc96f47 SHA512 756d35f9bdf0baa9ab383e16d88533f6e6a71defbf9db5ad202cb18d92c4f32cd9c11eb78a5c8648bfeaad14d9e9bb40c5731e030c7b2a4e9f174b66a2db7a8e WHIRLPOOL a9ea00594ee2bc3dd2d548ce7e994f58761a214e8989655463fa847eda0b567df1bae57fa34be0478619e28b722d916a43148aa9576adbd2784f7f2e8f9babb4
diff --git a/dev-haskell/void/metadata.xml b/dev-haskell/void/metadata.xml
new file mode 100644
index 000000000000..4c3a9ad04c11
--- /dev/null
+++ b/dev-haskell/void/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A Haskell 98 logically uninhabited data type. Used to indicate that a given term should not exist.
+ </longdescription>
+ <use>
+ <flag name="safe">dissable effective but unsafe coersions</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ekmett/void</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/void/void-0.6.1.ebuild b/dev-haskell/void/void-0.6.1.ebuild
new file mode 100644
index 000000000000..d7de33bb0f15
--- /dev/null
+++ b/dev-haskell/void/void-0.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A Haskell 98 logically uninhabited data type"
+HOMEPAGE="http://github.com/ekmett/void"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="safe"
+
+RDEPEND=">=dev-haskell/hashable-1.1:=[profile?]
+ >=dev-haskell/semigroups-0.8.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag safe safe)
+}
diff --git a/dev-haskell/void/void-0.6.ebuild b/dev-haskell/void/void-0.6.ebuild
new file mode 100644
index 000000000000..e9fbe261d5d4
--- /dev/null
+++ b/dev-haskell/void/void-0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A Haskell 98 logically uninhabited data type"
+HOMEPAGE="http://github.com/ekmett/void"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="safe"
+
+RDEPEND=">=dev-haskell/hashable-1.1:=[profile?]
+ >=dev-haskell/semigroups-0.8.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag safe safe)
+}
diff --git a/dev-haskell/void/void-0.7.ebuild b/dev-haskell/void/void-0.7.ebuild
new file mode 100644
index 000000000000..962692383d87
--- /dev/null
+++ b/dev-haskell/void/void-0.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A Haskell 98 logically uninhabited data type"
+HOMEPAGE="http://github.com/ekmett/void"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="safe"
+
+RDEPEND=">=dev-haskell/hashable-1.1:=[profile?]
+ >=dev-haskell/semigroups-0.8.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag safe safe)
+}