summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-15 22:40:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:21:34 +0000
commit9971d1d73692875d62b847fd2b163d9ae06d2708 (patch)
tree43c30f3ba2332d4608c1e6a013ddabe535c7b26b /dev-haskell/warp-tls/warp-tls-3.2.3.ebuild
parentdev-haskell/tls: bump up to 1.3.9 (diff)
downloadgentoo-9971d1d73692875d62b847fd2b163d9ae06d2708.tar.gz
gentoo-9971d1d73692875d62b847fd2b163d9ae06d2708.tar.bz2
gentoo-9971d1d73692875d62b847fd2b163d9ae06d2708.zip
dev-haskell/warp-tls: bump up to 3.2.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/warp-tls/warp-tls-3.2.3.ebuild')
-rw-r--r--dev-haskell/warp-tls/warp-tls-3.2.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/warp-tls/warp-tls-3.2.3.ebuild b/dev-haskell/warp-tls/warp-tls-3.2.3.ebuild
new file mode 100644
index 000000000000..703da369d254
--- /dev/null
+++ b/dev-haskell/warp-tls/warp-tls-3.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: +tls_1_1_3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP over TLS support for Warp via the TLS package"
+HOMEPAGE="https://github.com/yesodweb/wai"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cryptonite-0.12:=[profile?]
+ >=dev-haskell/data-default-class-0.0.1:=[profile?]
+ >=dev-haskell/network-2.2.1:=[profile?]
+ dev-haskell/streaming-commons:=[profile?]
+ >=dev-haskell/tls-1.3.5:=[profile?]
+ >=dev-haskell/wai-3.2:=[profile?] <dev-haskell/wai-3.3:=[profile?]
+ >=dev-haskell/warp-3.2.10:=[profile?] <dev-haskell/warp-3.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=tls_1_1_3
+}