summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-09-11 10:49:30 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-09-11 11:01:32 +0100
commit0f2c6476e1f4c22dd308195a36f979dd15079413 (patch)
treeb2f997c1b4fb45b5723d6ffd96757f8e3c574d1b /dev-haskell/wavy/wavy-0.1.0.0.ebuild
parentdev-haskell/riff: RIFF file parser, a depend of dev-haskell/wavy (diff)
downloadgentoo-0f2c6476e1f4c22dd308195a36f979dd15079413.tar.gz
gentoo-0f2c6476e1f4c22dd308195a36f979dd15079413.tar.bz2
gentoo-0f2c6476e1f4c22dd308195a36f979dd15079413.zip
dev-haskell/wavy: WAV file processor, a depend of app-forensics/quickfuzz
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-haskell/wavy/wavy-0.1.0.0.ebuild')
-rw-r--r--dev-haskell/wavy/wavy-0.1.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/wavy/wavy-0.1.0.0.ebuild b/dev-haskell/wavy/wavy-0.1.0.0.ebuild
new file mode 100644
index 000000000000..fc58013e118c
--- /dev/null
+++ b/dev-haskell/wavy/wavy-0.1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Process WAVE files in Haskell"
+HOMEPAGE="http://bitbucket.org/robertmassaioli/wavy"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/pretty-show:=[profile?]
+ >=dev-haskell/riff-0.3:=[profile?] <dev-haskell/riff-0.4:=[profile?]
+ >=dev-haskell/split-0.2:=[profile?] <dev-haskell/split-0.3:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+PATCHES=("${FILESDIR}"/${P}-binary-0.8.patch)
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'vector ==0.10.*' 'vector >= 0.10' \
+ 'filepath ==1.3.*' 'filepath >= 1.3' \
+ 'binary ==0.7.*' 'binary >= 0.7' \
+ 'containers ==0.4.*' 'containers >= 0.4'
+}