summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-09 19:27:37 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-09 19:27:37 +0100
commit6bfd43bee6d167c7ebe3f3cc9baa65bc52d75ab2 (patch)
tree5c47e1cca09e548671caa883749cc1aae8e2e046 /dev-haskell/wavy
parentdev-haskell/wreq: RESTRICT=test, needs network (diff)
downloadgentoo-6bfd43bee6d167c7ebe3f3cc9baa65bc52d75ab2.tar.gz
gentoo-6bfd43bee6d167c7ebe3f3cc9baa65bc52d75ab2.tar.bz2
gentoo-6bfd43bee6d167c7ebe3f3cc9baa65bc52d75ab2.zip
dev-haskell/wavy: tweak for ghc-8.8
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/736444 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/wavy')
-rw-r--r--dev-haskell/wavy/files/wavy-0.1.0.0-ghc-8.8.patch11
-rw-r--r--dev-haskell/wavy/wavy-0.1.0.0.ebuild9
2 files changed, 17 insertions, 3 deletions
diff --git a/dev-haskell/wavy/files/wavy-0.1.0.0-ghc-8.8.patch b/dev-haskell/wavy/files/wavy-0.1.0.0-ghc-8.8.patch
new file mode 100644
index 000000000000..5d5fdee9bd24
--- /dev/null
+++ b/dev-haskell/wavy/files/wavy-0.1.0.0-ghc-8.8.patch
@@ -0,0 +1,11 @@
+--- a/Sound/Wav/ChannelData.hs
++++ b/Sound/Wav/ChannelData.hs
+@@ -111,7 +111,7 @@ wordPutter 1 = putInt8 . zeroStable (0 :: Int8)
+ wordPutter 2 = putInt16le . zeroStable (0 :: Int16)
+ wordPutter 3 = putInt32le . zeroStable (0 :: Int32)
+ wordPutter 4 = putInt64le
+-wordPutter x = \_ -> fail $ "The is no word putter for byte size " ++ show x
++wordPutter x = \_ -> error $ "The is no word putter for byte size " ++ show x
+
+ wordGetter :: (Num a, Show a, Eq a) => a -> Get Int64
+ wordGetter 1 = fmap zeroStable64 getInt8
diff --git a/dev-haskell/wavy/wavy-0.1.0.0.ebuild b/dev-haskell/wavy/wavy-0.1.0.0.ebuild
index 92dff5552602..bfc61294c40e 100644
--- a/dev-haskell/wavy/wavy-0.1.0.0.ebuild
+++ b/dev-haskell/wavy/wavy-0.1.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,7 +9,7 @@ CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Process WAVE files in Haskell"
-HOMEPAGE="https://bitbucket.org/robertmassaioli/wavy"
+HOMEPAGE="http://bitbucket.org/robertmassaioli/wavy"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
@@ -27,7 +27,10 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
"
-PATCHES=("${FILESDIR}"/${P}-binary-0.8.patch)
+PATCHES=(
+ "${FILESDIR}"/${P}-binary-0.8.patch
+ "${FILESDIR}"/${P}-ghc-8.8.patch
+)
src_prepare() {
default