summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-05-24 22:18:10 +0200
committerPacho Ramos <pacho@gentoo.org>2016-05-24 22:18:56 +0200
commitca4dfa10c113542175ae8d30252f1a64abf9dbae (patch)
treecb87552740aad26ced62de93fd868ced1d75f87e /dev-haskell/wxcore
parentapp-text/po4a: arm stable, bug #582428 (diff)
downloadgentoo-ca4dfa10c113542175ae8d30252f1a64abf9dbae.tar.gz
gentoo-ca4dfa10c113542175ae8d30252f1a64abf9dbae.tar.bz2
gentoo-ca4dfa10c113542175ae8d30252f1a64abf9dbae.zip
dev-haskell/wxcore: Needed by some reverse deps
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-haskell/wxcore')
-rw-r--r--dev-haskell/wxcore/Manifest1
-rw-r--r--dev-haskell/wxcore/files/wxcore-0.13.2.3-ghc-7.6.patch42
-rw-r--r--dev-haskell/wxcore/files/wxcore-0.13.2.3-stdcpp.patch6
-rw-r--r--dev-haskell/wxcore/files/wxcore-0.90.0.1-ghc-7.5.patch29
-rw-r--r--dev-haskell/wxcore/files/wxcore-0.90.1.1-ghc-7.5.patch18
-rw-r--r--dev-haskell/wxcore/wxcore-0.13.2.3-r1.ebuild45
6 files changed, 141 insertions, 0 deletions
diff --git a/dev-haskell/wxcore/Manifest b/dev-haskell/wxcore/Manifest
index 5bf04f4e5710..5ab175abc875 100644
--- a/dev-haskell/wxcore/Manifest
+++ b/dev-haskell/wxcore/Manifest
@@ -1 +1,2 @@
+DIST wxcore-0.13.2.3.tar.gz 539251 SHA256 e02aab9b0d1084c723fafaf759576cc7a4800d3112d0f99923e88f75cec8ee57 SHA512 9745819c35a1ff4a287a992e146126df1170cacc8702d4a647ec9a4a3ead0518f015a6068858e035b4e30c165c3b84bc5251cd27c554d3271a6fab02f107d264 WHIRLPOOL 13e68eeb85b23104349990d03bdde6010f0ee8c046ec350cf4921fb723fc7f7c0d99b5565e0c40241601b8a3d9561a239dabd305c8096480e858fbd0e4ebf015
DIST wxcore-0.92.2.0.tar.gz 400116 SHA256 76128916c5d5df9cea9fc1e1b3b56d800d87874a431e98fca4427cb41cfe283e SHA512 e1339ea30a699e22a9fc2f12b6ddcd773911e4d611f834886952bde4d76205c448e1702bab3148f4c370eec1cabeac06655b4cf3cbbfe24e2ea08a628906880a WHIRLPOOL 60e37835d5d13d116659bed858b1320ba5006fd119cc9f045ca02b0d381de73146f52fb7308ee95a752a0aa4921532258468d69ed054c7ece67f0e8bf63a9f3b
diff --git a/dev-haskell/wxcore/files/wxcore-0.13.2.3-ghc-7.6.patch b/dev-haskell/wxcore/files/wxcore-0.13.2.3-ghc-7.6.patch
new file mode 100644
index 000000000000..3d5adbea0904
--- /dev/null
+++ b/dev-haskell/wxcore/files/wxcore-0.13.2.3-ghc-7.6.patch
@@ -0,0 +1,42 @@
+--- wxcore-0.13.2.3-orig/src/haskell/Graphics/UI/WXCore/Events.hs 2012-09-30 19:56:52.000000000 +1000
++++ wxcore-0.13.2.3/src/haskell/Graphics/UI/WXCore/Events.hs 2013-01-13 10:08:50.415293002 +1100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE ForeignFunctionInterface #-}
++{-# LANGUAGE CPP, ForeignFunctionInterface #-}
+ -----------------------------------------------------------------------------------------
+ {-| Module : Events
+ Copyright : (c) Daan Leijen 2003
+@@ -241,6 +241,9 @@
+ import Foreign.Marshal.Alloc
+ import Foreign.Marshal.Array
+ import Foreign.Marshal.Utils
++#if (__GLASGOW_HASKELL__>=705)
++import Foreign.C.Types(CInt(..))
++#endif
+
+ import Data.Char ( chr ) -- used in stc
+ import Data.Maybe ( fromMaybe, fromJust )
+--- wxcore-0.13.2.3-orig/src/haskell/Graphics/UI/WXCore/WxcTypes.hs 2012-09-30 19:56:52.000000000 +1000
++++ wxcore-0.13.2.3/src/haskell/Graphics/UI/WXCore/WxcTypes.hs 2013-01-13 10:08:50.420293137 +1100
+@@ -142,7 +142,12 @@
+
+ import Data.Int
+ import Data.Word
++#ifdef MIN_VERSION_base(4,5,0)
++import Debug.Trace (traceIO)
++#else
+ import Debug.Trace (putTraceMsg)
++#define traceIO putTraceMsg
++#endif
+
+ import Graphics.UI.WXCore.WxcObject
+ import Graphics.UI.WXCore.WxcClassTypes
+@@ -853,7 +858,7 @@
+ withCharResult io
+ = do x <- io
+ if (x < 0)
+- then do putTraceMsg ("Recieved negative unicode: " ++ (show x))
++ then do traceIO ("Recieved negative unicode: " ++ (show x))
+ return '\n'
+ else return (fromCWchar x)
+
diff --git a/dev-haskell/wxcore/files/wxcore-0.13.2.3-stdcpp.patch b/dev-haskell/wxcore/files/wxcore-0.13.2.3-stdcpp.patch
new file mode 100644
index 000000000000..e09f9fa5594a
--- /dev/null
+++ b/dev-haskell/wxcore/files/wxcore-0.13.2.3-stdcpp.patch
@@ -0,0 +1,6 @@
+diff --git a/wxcore.cabal b/wxcore.cabal
+index 886c77d..e1bfeb6 100644
+--- a/wxcore.cabal
++++ b/wxcore.cabal
+@@ -173,0 +174 @@ library
++ extra-libraries: stdc++
diff --git a/dev-haskell/wxcore/files/wxcore-0.90.0.1-ghc-7.5.patch b/dev-haskell/wxcore/files/wxcore-0.90.0.1-ghc-7.5.patch
new file mode 100644
index 000000000000..08f0f5bc27d2
--- /dev/null
+++ b/dev-haskell/wxcore/files/wxcore-0.90.0.1-ghc-7.5.patch
@@ -0,0 +1,29 @@
+--- wxcore-0.90.0.1-orig/wxcore.cabal 2012-05-15 06:26:55.000000000 +1000
++++ wxcore-0.90.0.1/wxcore.cabal 2012-05-19 21:32:01.230849131 +1000
+@@ -80,7 +80,7 @@
+ build-depends:
+ array >= 0.2 && < 0.5,
+ base >= 4 && < 5,
+- containers >= 0.2 && < 0.5
++ containers >= 0.2 && < 0.6
+ else
+ build-depends:
+ array >= 0.1 && < 0.3,
+--- wxcore-0.90.0.1-orig/src/haskell/Graphics/UI/WXCore/Events.hs 2012-05-15 06:26:55.000000000 +1000
++++ wxcore-0.90.0.1/src/haskell/Graphics/UI/WXCore/Events.hs 2012-05-19 21:44:09.457185166 +1000
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE ForeignFunctionInterface #-}
++{-# LANGUAGE CPP, ForeignFunctionInterface #-}
+ -----------------------------------------------------------------------------------------
+ {-| Module : Events
+ Copyright : (c) Daan Leijen 2003
+@@ -245,6 +245,9 @@
+ import Foreign.Marshal.Alloc
+ import Foreign.Marshal.Array
+ import Foreign.Marshal.Utils
++#if (__GLASGOW_HASKELL__>=705)
++import Foreign.C.Types(CInt(..))
++#endif
+
+ import Data.Char ( chr ) -- used in stc
+ import Data.Maybe ( fromMaybe, fromJust )
diff --git a/dev-haskell/wxcore/files/wxcore-0.90.1.1-ghc-7.5.patch b/dev-haskell/wxcore/files/wxcore-0.90.1.1-ghc-7.5.patch
new file mode 100644
index 000000000000..ee2405dce90e
--- /dev/null
+++ b/dev-haskell/wxcore/files/wxcore-0.90.1.1-ghc-7.5.patch
@@ -0,0 +1,18 @@
+--- wxcore-0.90.1.1-orig/src/haskell/Graphics/UI/WXCore/Events.hs 2014-03-23 08:01:17.000000000 +1100
++++ wxcore-0.90.1.1/src/haskell/Graphics/UI/WXCore/Events.hs 2014-03-23 17:05:26.428738461 +1100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE ForeignFunctionInterface #-}
++{-# LANGUAGE CPP, ForeignFunctionInterface #-}
+ -----------------------------------------------------------------------------------------
+ {-| Module : Events
+ Copyright : (c) Daan Leijen 2003
+@@ -248,6 +248,9 @@
+ import Foreign.Marshal.Alloc
+ import Foreign.Marshal.Array
+ import Foreign.Marshal.Utils
++#if (__GLASGOW_HASKELL__>=705)
++import Foreign.C.Types(CInt(..))
++#endif
+
+ import Data.Char ( chr ) -- used in stc
+ import Data.Maybe ( fromMaybe, fromJust )
diff --git a/dev-haskell/wxcore/wxcore-0.13.2.3-r1.ebuild b/dev-haskell/wxcore/wxcore-0.13.2.3-r1.ebuild
new file mode 100644
index 000000000000..e29d7a649bbc
--- /dev/null
+++ b/dev-haskell/wxcore/wxcore-0.13.2.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal wxwidgets
+
+DESCRIPTION="wxHaskell core"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/parsec:=[profile?]
+ dev-haskell/stm:=[profile?]
+ >dev-haskell/wxdirect-0.12.1.2:${WX_GTK_VER}=[profile?]
+ <dev-haskell/wxdirect-0.90:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ x11-libs/wxGTK:${WX_GTK_VER}=[X,gstreamer,opengl]"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+PATCHES=("${FILESDIR}/${PN}"-0.13.2.3-ghc-7.6.patch
+ "${FILESDIR}/${PN}"-0.13.2.3-stdcpp.patch)
+
+src_prepare() {
+ base_src_prepare
+ sed -e "s@wxdirect@wxdirect-${WX_GTK_VER}@g" \
+ -i "${S}/Setup.hs" \
+ || die "Could not change Setup.hs for wxdirect slot ${WX_GTK_VER}"
+ cabal_chdeps \
+ 'array >= 0.2 && < 0.5' 'array >= 0.2'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=splitbase
+}