summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/zlib-conduit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/zlib-conduit')
-rw-r--r--dev-haskell/zlib-conduit/Manifest2
-rw-r--r--dev-haskell/zlib-conduit/metadata.xml11
-rw-r--r--dev-haskell/zlib-conduit/zlib-conduit-1.0.0.ebuild37
-rw-r--r--dev-haskell/zlib-conduit/zlib-conduit-1.1.0.ebuild26
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-haskell/zlib-conduit/Manifest b/dev-haskell/zlib-conduit/Manifest
new file mode 100644
index 000000000000..948b3c764d15
--- /dev/null
+++ b/dev-haskell/zlib-conduit/Manifest
@@ -0,0 +1,2 @@
+DIST zlib-conduit-1.0.0.tar.gz 3461 SHA256 7b81c7902e7c0b3fc1ec089764d4eaa11fa2964020121b8e949c091738261460 SHA512 3f62701b687ab0220c2f5f18ebc2b9ba33010ed4471832523400cea4a808d02f59173c2de4ee3055f09ec6271a771745df35768612f8035d98c9dcd32be9b007 WHIRLPOOL f00cd532a817a9714f62ff196ad45d159a12aa539d45e78b9dd42596a89448d62835ea1d9105e972ac46b737c30492de33a684bf8859284fce7875ee76bae2c6
+DIST zlib-conduit-1.1.0.tar.gz 2024 SHA256 6aa47ff9c2bdf5b34e3fc21bb1026fe2fdc9cad21878040972e7ad8514ab42ac SHA512 5d19fa0e144b8e124486465c00b984f2e16f51e8ef0bc246fafd64b173e7dcef5b12f8cb431bb6071e4dab4a8c8f62606d47feb2cac2e36c1894216a9c8a32d9 WHIRLPOOL d902b4aaebf133e69a699ee1c65f72dedafa5e561c59c846d6dc48428dab30f808b989be163a4cbb3b6e5e5472585bc1f06e284e01ef3a4db0473e2135cd4201
diff --git a/dev-haskell/zlib-conduit/metadata.xml b/dev-haskell/zlib-conduit/metadata.xml
new file mode 100644
index 000000000000..abaee86cef49
--- /dev/null
+++ b/dev-haskell/zlib-conduit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Streaming compression/decompression via conduits.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">snoyberg/conduit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/zlib-conduit/zlib-conduit-1.0.0.ebuild b/dev-haskell/zlib-conduit/zlib-conduit-1.0.0.ebuild
new file mode 100644
index 000000000000..e04cf972f07f
--- /dev/null
+++ b/dev-haskell/zlib-conduit/zlib-conduit-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Streaming compression/decompression via conduits"
+HOMEPAGE="http://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="+debug"
+
+RDEPEND="=dev-haskell/conduit-1.0*:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ <dev-haskell/transformers-0.4:=[profile?]
+ dev-haskell/void:=[profile?]
+ =dev-haskell/zlib-bindings-0.1*:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck
+ dev-haskell/resourcet
+ )"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}
diff --git a/dev-haskell/zlib-conduit/zlib-conduit-1.1.0.ebuild b/dev-haskell/zlib-conduit/zlib-conduit-1.1.0.ebuild
new file mode 100644
index 000000000000..34f9777e0e59
--- /dev/null
+++ b/dev-haskell/zlib-conduit/zlib-conduit-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal
+
+DESCRIPTION="Streaming compression/decompression via conduits. (deprecated)"
+HOMEPAGE="http://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/conduit-1.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"