summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2021-04-18 13:14:20 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-19 09:42:11 +0100
commit72699608dde7fe22629dbb1ebcc272cd350da933 (patch)
tree4c7ec6c83a2a9ddf3df6c7207c4e8e32af8f0ebe /dev-haskell
parentdev-haskell/xml-conduit: drop old (diff)
downloadgentoo-72699608dde7fe22629dbb1ebcc272cd350da933.tar.gz
gentoo-72699608dde7fe22629dbb1ebcc272cd350da933.tar.bz2
gentoo-72699608dde7fe22629dbb1ebcc272cd350da933.zip
dev-haskell/skylighting-core: bump up to 0.10.5
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/skylighting-core/Manifest1
-rw-r--r--dev-haskell/skylighting-core/skylighting-core-0.10.5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/skylighting-core/Manifest b/dev-haskell/skylighting-core/Manifest
index ebd831534665..23c9b76b579a 100644
--- a/dev-haskell/skylighting-core/Manifest
+++ b/dev-haskell/skylighting-core/Manifest
@@ -1,2 +1,3 @@
DIST skylighting-core-0.10.2.tar.gz 695555 BLAKE2B b4ef476780b9cf613e8bc7150abc57f4bcc282321a31ff549bb4ffb518c2519aaddeb4c94ca974f79d6fe803729b444da4f6c01784dab1cf63b7a596f2676818 SHA512 c3d20694b29dee660cbba681dec4b7610b1b5be8e5b359931935b0e2a466f41a494847231557c6c5906d5b31487360516af0e00c46689cbc03c9de58e3430698
+DIST skylighting-core-0.10.5.tar.gz 711899 BLAKE2B 5f147c010a462c1ac8ac48c0b6c5502f91dd9e62a6e3e10d822aefcc81768e6b3d9cd34ac933d352ce14ea4d21e81e7e4b413373cfe616fb5a30f72416532d30 SHA512 cde536276f6c9bbae78cafa33016629ba2b78bcba317c88af3dac7cd384ce3028bc5733a644cac72e84810751faada2db51abe3a8c717b8db32a3f625fb9d7ba
DIST skylighting-core-0.8.5.tar.gz 675746 BLAKE2B 3a17423f5412228930df78e86b00b3d0339bced0a00e801a9986177f7099e9e5706b1858e3a4064db84eeec3b0fdde3f043b05b62de85d6a92d2d47a5cbb136d SHA512 ad411d7e0fd72adeb4cdbf6fc57d6191c51d9319b25c8d41ad35a66f885d518a842846cd7cf5ce35bdc31da74e0f9d97445f492628a4b5a2bceb85642aa23257
diff --git a/dev-haskell/skylighting-core/skylighting-core-0.10.5.ebuild b/dev-haskell/skylighting-core/skylighting-core-0.10.5.ebuild
new file mode 100644
index 000000000000..ff9c93f9c9c5
--- /dev/null
+++ b/dev-haskell/skylighting-core/skylighting-core-0.10.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: +system-pcre
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
+ >=dev-haskell/ansi-terminal-0.7:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ >=dev-haskell/colour-2.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-haskell/xml-conduit-1.9.1.0:=[profile?] <dev-haskell/xml-conduit-1.10:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/diff
+ dev-haskell/pretty-show
+ dev-haskell/quickcheck
+ dev-haskell/tasty
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ --flag=system-pcre
+}