summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-06 11:49:52 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-06 12:02:59 +0000
commit7ead905808dfc963e4a5bc7b56a27cec0d6dc36a (patch)
treebab622b7259eb64a0178ce197ffe4b2c68eb9e2f /dev-haskell
parentdev-haskell/quickcheck-io: bump up to 0.1.4 (diff)
downloadgentoo-7ead905808dfc963e4a5bc7b56a27cec0d6dc36a.tar.gz
gentoo-7ead905808dfc963e4a5bc7b56a27cec0d6dc36a.tar.bz2
gentoo-7ead905808dfc963e4a5bc7b56a27cec0d6dc36a.zip
dev-haskell/quickcheck-instances: allow QuickCheck-2.9
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/quickcheck-instances/quickcheck-instances-0.3.12-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.12-r1.ebuild b/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.12-r1.ebuild
new file mode 100644
index 000000000000..fba4cc9c235b
--- /dev/null
+++ b/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.12-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Common quickcheck instances"
+HOMEPAGE="https://github.com/aslatter/qc-instances"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-haskell/old-time-1.0:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
+ >=dev-haskell/quickcheck-2.1:2=[profile?]
+ >=dev-haskell/scientific-0.2:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?] <dev-haskell/vector-0.12:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >= 2.1 && < 2.9' 'QuickCheck >= 2.1'
+}