summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-09-02 08:45:56 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-02 08:46:09 +0100
commit8ec29738803f86d02f2abce0e541c3fc7e5c354d (patch)
tree1c7349ed2866330a825885d381cf93746eeb6cbe /dev-haskell
parentdev-haskell/lazysmallcheck: drop old (diff)
downloadgentoo-8ec29738803f86d02f2abce0e541c3fc7e5c354d.tar.gz
gentoo-8ec29738803f86d02f2abce0e541c3fc7e5c354d.tar.bz2
gentoo-8ec29738803f86d02f2abce0e541c3fc7e5c354d.zip
dev-haskell/shellish: remove masked package
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/shellish/Manifest1
-rw-r--r--dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch9
-rw-r--r--dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch9
-rw-r--r--dev-haskell/shellish/metadata.xml21
-rw-r--r--dev-haskell/shellish/shellish-0.1.4.ebuild30
5 files changed, 0 insertions, 70 deletions
diff --git a/dev-haskell/shellish/Manifest b/dev-haskell/shellish/Manifest
deleted file mode 100644
index 573922da1791..000000000000
--- a/dev-haskell/shellish/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST shellish-0.1.4.tar.gz 7268 BLAKE2B d315b956f64d6ebf9cd3728468b63775448fd6446fdbed8570ddc81885027884b2112c1377a457693463d42dc9f43c8088119f4fa09b8612dd830a504ffcb07b SHA512 4507ab92ca2db6a0e79d799ba303b3cb64fa887ec4581f0e1d191340fa7116db2c4bae069d6692c51d3d754ea0672b2d5c12b582d769b81b5b0e25c8c97c8a62
diff --git a/dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch b/dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch
deleted file mode 100644
index c756635f6000..000000000000
--- a/dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff --git a/Shellish.hs b/Shellish.hs
-index 1e3c192..0ac20c2 100644
---- a/Shellish.hs
-+++ b/Shellish.hs
-@@ -1,3 +1,3 @@
- {-# LANGUAGE ScopedTypeVariables, DeriveDataTypeable, OverloadedStrings,
-- MultiParamTypeClasses, FlexibleInstances #-}
-+ MultiParamTypeClasses, FlexibleInstances, FlexibleContexts #-}
-
diff --git a/dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch b/dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch
deleted file mode 100644
index 49525543acbd..000000000000
--- a/dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff --git a/Shellish.hs b/Shellish.hs
-index 0ac20c2..7de0e11 100644
---- a/Shellish.hs
-+++ b/Shellish.hs
-@@ -180,3 +180,3 @@ test_s = path >=> liftIO . \f -> do
- stat <- getSymbolicLinkStatus f
-- return $ isSymbolicLink stat
-+ return $ System.PosixCompat.Files.isSymbolicLink stat
-
diff --git a/dev-haskell/shellish/metadata.xml b/dev-haskell/shellish/metadata.xml
deleted file mode 100644
index 220975e213d9..000000000000
--- a/dev-haskell/shellish/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- The shellisg package provides a single module for convenient
- \"systems\" programming in Haskell, similar in spirit to POSIX
- shells or PERL.
-
- * Elegance and safety is sacrificed for conciseness and
- swiss-army-knife-ness.
-
- * The interface exported by Shellish is thread-safe.
-
- Overall, the module should help you to get a job done quickly,
- without getting too dirty.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-haskell/shellish/shellish-0.1.4.ebuild b/dev-haskell/shellish/shellish-0.1.4.ebuild
deleted file mode 100644
index b441415f3876..000000000000
--- a/dev-haskell/shellish/shellish-0.1.4.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# ebuild generated by hackport 0.2.17.9999
-
-EAPI=4
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="shell-/perl- like (systems) programming in Haskell"
-HOMEPAGE="http://repos.mornfall.net/shellish"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-haskell/mtl[profile?]
- dev-haskell/strict[profile?]
- dev-haskell/unix-compat[profile?]
- >=dev-lang/ghc-6.10.1"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ghc-7.10.patch
- epatch "${FILESDIR}"/${P}-ghc-8.patch
-}