summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-15 12:30:04 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-15 12:50:17 +0000
commit98e9e54d46b8ff5a00be53ce8f4df5e947ff063c (patch)
tree0e52304b3114f8b4f9dd44a1b3c5e04105b45392 /dev-haskell
parentnet-misc/s3cmd: x86 stable wrt bug #698390 (diff)
downloadgentoo-98e9e54d46b8ff5a00be53ce8f4df5e947ff063c.tar.gz
gentoo-98e9e54d46b8ff5a00be53ce8f4df5e947ff063c.tar.bz2
gentoo-98e9e54d46b8ff5a00be53ce8f4df5e947ff063c.zip
dev-haskell/tasty: tweak against unbounded-delays-0.1.1.0
The patch fixes the following build failure: ``` Test/Tasty/Run.hs:80:6: error: Ambiguous occurrence ‘Timeout’ It could refer to either ‘Control.Concurrent.Timeout.Timeout’, imported from ‘Control.Concurrent.Timeout’ at Test/Tasty/Run.hs:18:1-33 or ‘Test.Tasty.Options.Core.Timeout’, imported from ‘Test.Tasty.Options.Core’ at Test/Tasty/Run.hs:29:1-30 (and originally defined at Test/Tasty/Options/Core.hs:(54,1)-(60,27)) ``` Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/702906 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/tasty/files/tasty-0.11.0.4-unbounded-delays.patch26
-rw-r--r--dev-haskell/tasty/tasty-0.11.0.4.ebuild2
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-haskell/tasty/files/tasty-0.11.0.4-unbounded-delays.patch b/dev-haskell/tasty/files/tasty-0.11.0.4-unbounded-delays.patch
new file mode 100644
index 000000000000..ad265fdff295
--- /dev/null
+++ b/dev-haskell/tasty/files/tasty-0.11.0.4-unbounded-delays.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/702906
+
+From 74e87fff6a4a830dc64d59f4baa1a5f6759c007c Mon Sep 17 00:00:00 2001
+From: Roman Cheplyaka <roma@ro-che.info>
+Date: Fri, 5 May 2017 08:54:28 +0300
+Subject: [PATCH] Fix compatibility with the latest unbounded-delays
+
+Fixes #166
+---
+ core/Test/Tasty/Run.hs | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/Test/Tasty/Run.hs
++++ b/Test/Tasty/Run.hs
+@@ -15,7 +15,7 @@ import Control.Monad.State
+ import Control.Monad.Writer
+ import Control.Monad.Reader
+ import Control.Concurrent.STM
+-import Control.Concurrent.Timeout
++import Control.Concurrent.Timeout (timeout)
+ import Control.Concurrent.Async
+ import Control.Exception as E
+ import Control.Applicative
+--
+2.24.1
+
diff --git a/dev-haskell/tasty/tasty-0.11.0.4.ebuild b/dev-haskell/tasty/tasty-0.11.0.4.ebuild
index 9c138e80dd26..4de53058744c 100644
--- a/dev-haskell/tasty/tasty-0.11.0.4.ebuild
+++ b/dev-haskell/tasty/tasty-0.11.0.4.ebuild
@@ -17,6 +17,8 @@ SLOT="0/${PV}"
KEYWORDS="amd64 x86"
IUSE=""
+PATCHES=("${FILESDIR}"/${P}-unbounded-delays.patch)
+
RDEPEND=">=dev-haskell/ansi-terminal-0.6.2:=[profile?]
>=dev-haskell/async-2.0:=[profile?]
>=dev-haskell/clock-0.4.4.0:=[profile?]