summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:01:07 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:56:59 +0000
commitb215da3740ff481cd12de54802161cc08449077d (patch)
treeacc7ffa7f97dea854eea597d1d11cf6a8815325d /dev-haskell
parentdev-haskell/hspec-discover: bump up to 2.2.4 (diff)
downloadgentoo-b215da3740ff481cd12de54802161cc08449077d.tar.gz
gentoo-b215da3740ff481cd12de54802161cc08449077d.tar.bz2
gentoo-b215da3740ff481cd12de54802161cc08449077d.zip
dev-haskell/aeson-pretty: bump up to 0.8.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/aeson-pretty/Manifest1
-rw-r--r--dev-haskell/aeson-pretty/aeson-pretty-0.8.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/aeson-pretty/Manifest b/dev-haskell/aeson-pretty/Manifest
index 39f791910a2e..8d903b1e85d7 100644
--- a/dev-haskell/aeson-pretty/Manifest
+++ b/dev-haskell/aeson-pretty/Manifest
@@ -1,2 +1,3 @@
DIST aeson-pretty-0.7.1.tar.gz 4811 SHA256 c68ff70d0149a6f1f38345393cc0493d5ce6bfb22fc8e89bf3ceaad5ea0cb53e SHA512 53522c5235b8252c0a293ebe6a988cfb7f61cc575df664a27851652a47b948acd322898e70e128c91d1aaf6b5bd27c8a1717edcc3ea423f34e7943791a301326 WHIRLPOOL c4a311a05ca7ef0613fc458140dbaf2a2dac00c27c1afcbd868b88fec68c7b9a3de309051a8f143ed8a499b286ac95680c41809eabccf6aeab9b08e81f2e993d
DIST aeson-pretty-0.7.2.tar.gz 4838 SHA256 6408b8b2bcd12cf591e4b93b4d9f5143449b33a59fbd3653f328e2515040570d SHA512 beabdb13c1a7c5a8fa7acdfe0e0f7b6b00d901d6aada360c17e43704cddd92d6464901885dd529710cc090c9649aa63b7241a5155178f0ff27145ed1ef4f347b WHIRLPOOL 8bab7c7527312a3c61f0232482f7b2418ae13a7d16d6b586278795a38ea8703830da68d2582e0a0dfee404a3c457c36934de8adcde882111bdc96f3ce274e574
+DIST aeson-pretty-0.8.2.tar.gz 5456 SHA256 6cb429821040bdd6f819b1c6170cac630a4155fa57fa24eb3d496c06030fb9b0 SHA512 ec3af960b6afff9eb25d3679c23f8c627b9baeb0c10bcd9eb1ac60cc118988e6e47904d7e93bb4e260578fa41b58cfa7bd797fa5e0043c985a8f2b574b7d243a WHIRLPOOL 2e5a3aa93af902972d0da38358a950d40cc6308b42eea4af6747c701241fb535e287cae9f389042d046fc96322a5efc6fc80ac47dee6d1014528364f970250ee
diff --git a/dev-haskell/aeson-pretty/aeson-pretty-0.8.2.ebuild b/dev-haskell/aeson-pretty/aeson-pretty-0.8.2.ebuild
new file mode 100644
index 000000000000..74e2fb8cccee
--- /dev/null
+++ b/dev-haskell/aeson-pretty/aeson-pretty-0.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON pretty-printing library and command-line tool"
+HOMEPAGE="https://github.com/informatikr/aeson-pretty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="lib-only"
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
+ >=dev-haskell/base-compat-0.9:=[profile?] <dev-haskell/base-compat-0.10:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.3.0:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ !lib-only? ( >=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/cmdargs-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lib-only lib-only)
+}