summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-02-06 14:35:53 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-02-06 14:35:53 +0000
commitbcaeae87be7a6df5341e903782dc46e373dcbe3a (patch)
tree2b56dc794e27edde0aaee5d7a6f8e35b97043bea /dev-haskell
parentapp-portage/fquery: drop old (diff)
downloadgentoo-bcaeae87be7a6df5341e903782dc46e373dcbe3a.tar.gz
gentoo-bcaeae87be7a6df5341e903782dc46e373dcbe3a.tar.bz2
gentoo-bcaeae87be7a6df5341e903782dc46e373dcbe3a.zip
dev-haskell/arithmoi: initial import, numeric library
Efficient basic number-theoretic functions. Primes, powers, integer logarithms for haskell. Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/arithmoi/Manifest1
-rw-r--r--dev-haskell/arithmoi/arithmoi-0.4.1.3.ebuild34
-rw-r--r--dev-haskell/arithmoi/metadata.xml19
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/arithmoi/Manifest b/dev-haskell/arithmoi/Manifest
new file mode 100644
index 000000000000..8f8f9bd82336
--- /dev/null
+++ b/dev-haskell/arithmoi/Manifest
@@ -0,0 +1 @@
+DIST arithmoi-0.4.1.3.tar.gz 66196 SHA256 2e623924079d3f8733fd31bf40a30ee0051dd0c3e3ae4b13a7afb5f2300413c9 SHA512 abc5939207e502dffd91b3a4e2b9c688eef388a6b9354576fcb4badf4625da1cad0e9698cb42b293b37cc29427ad2679170452374fbf6cd5e614d53db34cd9f6 WHIRLPOOL dc0c167e63430d8f57fef7107f8444fa2fb1e76a5664043524df6c606f778cbecb457c43d9b1484015b96d4f91c221e60718f637593362ad657e7c5a5ae24a48
diff --git a/dev-haskell/arithmoi/arithmoi-0.4.1.3.ebuild b/dev-haskell/arithmoi/arithmoi-0.4.1.3.ebuild
new file mode 100644
index 000000000000..3cff83711c19
--- /dev/null
+++ b/dev-haskell/arithmoi/arithmoi-0.4.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: -llvm
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient basic number-theoretic functions. Primes, powers, integer logarithms"
+HOMEPAGE="https://github.com/cartazio/arithmoi"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/hspec )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-llvm
+}
diff --git a/dev-haskell/arithmoi/metadata.xml b/dev-haskell/arithmoi/metadata.xml
new file mode 100644
index 000000000000..8aefef709b4b
--- /dev/null
+++ b/dev-haskell/arithmoi/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A library of basic functionality needed for
+ number-theoretic calculations. The aim of this library
+ is to provide efficient implementations of the functions.
+ Primes and related things (totients, factorisation),
+ powers (integer roots and tests, modular exponentiation),
+ integer logarithms.
+ Note: Requires GHC &gt;= 6.12 with the integer-gmp package
+ for efficiency. Portability is on the to-do list (with
+ low priority, however).
+ </longdescription>
+</pkgmetadata>