summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-07-01 19:23:07 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-07-01 19:23:45 +0100
commitf12a95172b8c2d017b7916972fdb7f9e2bd7ca65 (patch)
tree23bf3aacd7a520507f25cea5c0174b39c2c6a902 /dev-haskell
parentdev-ada/gnat_util: 2017 version is only compatible with gnat-gpl-2017 (diff)
downloadgentoo-f12a95172b8c2d017b7916972fdb7f9e2bd7ca65.tar.gz
gentoo-f12a95172b8c2d017b7916972fdb7f9e2bd7ca65.tar.bz2
gentoo-f12a95172b8c2d017b7916972fdb7f9e2bd7ca65.zip
dev-haskell/vector-algorithms: fix test on ghc-8, bug #623326
Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/623326 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/vector-algorithms/files/vector-algorithms-0.7.0.1-ghc-8.0.2_rc1.patch44
-rw-r--r--dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild6
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-haskell/vector-algorithms/files/vector-algorithms-0.7.0.1-ghc-8.0.2_rc1.patch b/dev-haskell/vector-algorithms/files/vector-algorithms-0.7.0.1-ghc-8.0.2_rc1.patch
new file mode 100644
index 000000000000..3616dd76d82c
--- /dev/null
+++ b/dev-haskell/vector-algorithms/files/vector-algorithms-0.7.0.1-ghc-8.0.2_rc1.patch
@@ -0,0 +1,44 @@
+diff --git a/tests/properties/Tests.hs b/tests/properties/Tests.hs
+index a0b7d35..8fcfd36 100644
+--- a/tests/properties/Tests.hs
++++ b/tests/properties/Tests.hs
+@@ -1,2 +1,2 @@
+-{-# LANGUAGE ImpredicativeTypes, RankNTypes, TypeOperators, FlexibleContexts #-}
++{-# LANGUAGE ImpredicativeTypes, RankNTypes, TypeOperators, FlexibleContexts, ScopedTypeVariables #-}
+
+@@ -44,4 +44,4 @@ args = stdArgs
+
+-check_Int_sort = forM_ algos $ \(name,algo) ->
+- quickCheckWith args (label name . prop_fullsort algo)
++check_Int_sort = forM_ algos (\(name,algo :: Algo Int ()) ->
++ quickCheckWith args (label name . prop_fullsort algo))
+ where
+@@ -55,4 +55,4 @@ check_Int_sort = forM_ algos $ \(name,algo) ->
+
+-check_Int_partialsort = forM_ algos $ \(name,algo) ->
+- quickCheckWith args (label name . prop_partialsort algo)
++check_Int_partialsort = forM_ algos (\(name,algo :: SizeAlgo Int ()) ->
++ quickCheckWith args (label name . prop_partialsort algo))
+ where
+@@ -63,4 +63,4 @@ check_Int_partialsort = forM_ algos $ \(name,algo) ->
+
+-check_Int_select = forM_ algos $ \(name,algo) ->
+- quickCheckWith args (label name . prop_select algo)
++check_Int_select = forM_ algos (\(name,algo :: SizeAlgo Int ()) ->
++ quickCheckWith args (label name . prop_select algo))
+ where
+@@ -119,10 +119,10 @@ check_permutation = do
+ qc $ label "introsort" . prop_permutation (INT.sort :: Algo Int ())
+- qc $ label "intropartial" . prop_sized (const . prop_permutation)
++ qc $ label "intropartial" . prop_sized (\x -> const (prop_permutation x))
+ (INT.partialSort :: SizeAlgo Int ())
+- qc $ label "introselect" . prop_sized (const . prop_permutation)
++ qc $ label "introselect" . prop_sized (\x -> const (prop_permutation x))
+ (INT.select :: SizeAlgo Int ())
+ qc $ label "heapsort" . prop_permutation (H.sort :: Algo Int ())
+- qc $ label "heappartial" . prop_sized (const . prop_permutation)
++ qc $ label "heappartial" . prop_sized (\x -> const (prop_permutation x))
+ (H.partialSort :: SizeAlgo Int ())
+- qc $ label "heapselect" . prop_sized (const . prop_permutation)
++ qc $ label "heapselect" . prop_sized (\x -> const (prop_permutation x))
+ (H.select :: SizeAlgo Int ())
diff --git a/dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild b/dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild
index aae9913a543d..131da53ff676 100644
--- a/dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild
+++ b/dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
# ebuild generated by hackport 0.4.6.9999
@@ -28,6 +28,8 @@ DEPEND="${RDEPEND}
test? ( properties? ( >=dev-haskell/quickcheck-2 ) )
"
+PATCHES=("${FILESDIR}"/${P}-ghc-8.0.2_rc1.patch)
+
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bench bench) \