summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-11-05 21:53:01 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-11-05 22:49:10 +0000
commit096a349164b7228e1c6ae8293cf9b8defc4000c1 (patch)
tree85d90077b5ff8b322af846d31e5f7811845e8895 /dev-java/animal-sniffer-annotations/animal-sniffer-annotations-1.15.ebuild
parentdev-python/graph-tool: clean up old. (diff)
downloadgentoo-096a349164b7228e1c6ae8293cf9b8defc4000c1.tar.gz
gentoo-096a349164b7228e1c6ae8293cf9b8defc4000c1.tar.bz2
gentoo-096a349164b7228e1c6ae8293cf9b8defc4000c1.zip
dev-java/animal-sniffer-annotations: New package, required by guava
Thanks to wltjr for the initial work on this. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-java/animal-sniffer-annotations/animal-sniffer-annotations-1.15.ebuild')
-rw-r--r--dev-java/animal-sniffer-annotations/animal-sniffer-annotations-1.15.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/animal-sniffer-annotations/animal-sniffer-annotations-1.15.ebuild b/dev-java/animal-sniffer-annotations/animal-sniffer-annotations-1.15.ebuild
new file mode 100644
index 000000000000..ec63e0335ec7
--- /dev/null
+++ b/dev-java/animal-sniffer-annotations/animal-sniffer-annotations-1.15.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN%-annotations}"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java annotations for marking methods that Animal Sniffer should ignore"
+HOMEPAGE="http://www.mojohaus.org/animal-sniffer/animal-sniffer-annotations/"
+SRC_URI="https://github.com/mojohaus/${MY_PN}/archive/${MY_PN}-parent-${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/${MY_PN}-${MY_PN}-parent-${PV}/${PN}"
+JAVA_SRC_DIR="src/main/java"