summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/ant-junit4/ant-junit4-1.9.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/ant-junit4/ant-junit4-1.9.2.ebuild')
-rw-r--r--dev-java/ant-junit4/ant-junit4-1.9.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/ant-junit4/ant-junit4-1.9.2.ebuild b/dev-java/ant-junit4/ant-junit4-1.9.2.ebuild
new file mode 100644
index 000000000000..8edd055f37a1
--- /dev/null
+++ b/dev-java/ant-junit4/ant-junit4-1.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+ANT_TASK_JDKVER=1.5
+ANT_TASK_JREVER=1.5
+ANT_TASK_DEPNAME="junit-4"
+
+inherit ant-tasks
+
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+
+DEPEND="dev-java/junit:4
+ ~dev-java/ant-junit-${PV}"
+
+RDEPEND="${DEPEND}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="junit-4,ant-junit"
+
+src_compile() {
+ eant jar-junit4
+}
+
+src_install() {
+ # No registration as ant-task, would be loaded together with ant-junit.
+ java-pkg_dojar build/lib/ant-junit4.jar
+
+ # As we dont't want to depend on and-junit in package.env, because it depends
+ # on junit:0. Instead, we "steal" its jar and record it to our package.env as
+ # if it belongs to this package's classpath.
+ java-pkg_getjar --build-only ant-junit ant-junit.jar
+ java-pkg_regjar $(java-pkg_getjar --build-only ant-junit ant-junit.jar)
+}