summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKaibo Ma <kaiboma06@gmail.com>2021-02-20 15:36:14 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2021-02-23 10:13:43 +0100
commita5db61dfb375fc90fe5846215f86346998c85229 (patch)
tree1357dce59a209205e62ac930a7b1f176dead40b7 /dev-java/asm-commons
parentdev-java/commons-lang: bump to 3.11 (diff)
downloadgentoo-a5db61dfb375fc90fe5846215f86346998c85229.tar.gz
gentoo-a5db61dfb375fc90fe5846215f86346998c85229.tar.bz2
gentoo-a5db61dfb375fc90fe5846215f86346998c85229.zip
dev-java/asm{,-*}: new packages and version bumps
dev-java/asm bumped to the latest versions, because upstream doesn't publish asm-all anymore, we should also split it into components. The dependencies are as follows: - asm: no dependency - asm-tree: asm - asm-analysis: asm, asm-tree - asm-commons and asm-util: asm, asm-tree, asm-analysis Testing is still restricted because it uses JUnit 5 for testing. Signed-off-by: Kaibo Ma <kaiboma06@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19473 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/asm-commons')
-rw-r--r--dev-java/asm-commons/Manifest4
-rw-r--r--dev-java/asm-commons/asm-commons-6.2.1.ebuild27
-rw-r--r--dev-java/asm-commons/asm-commons-7.3.1.ebuild27
-rw-r--r--dev-java/asm-commons/asm-commons-8.0.1.ebuild27
-rw-r--r--dev-java/asm-commons/asm-commons-9.1.ebuild27
-rw-r--r--dev-java/asm-commons/metadata.xml26
6 files changed, 138 insertions, 0 deletions
diff --git a/dev-java/asm-commons/Manifest b/dev-java/asm-commons/Manifest
new file mode 100644
index 000000000000..307d3ed55e32
--- /dev/null
+++ b/dev-java/asm-commons/Manifest
@@ -0,0 +1,4 @@
+DIST asm-ASM_6_2_1.tar.gz 1509237 BLAKE2B fb287ff5346b2fd0a016e7744d44387d2973f89c4d1cfe7b46b864019a56443e71ea0a847940f49db2a2b359651297b65feca236cb1c847e0a9217117f9300b9 SHA512 93e2e4c386b5ae8f459830cf708d62bf96aa35353e93ae9c07005467afc684596281ecc32e4a9441aa9787731c0e8f8967ec9c797c4392f80ee3e828f5c39cff
+DIST asm-ASM_7_3_1.tar.gz 1556552 BLAKE2B 23d7b21de9c163e2e69b8edb5d5d72a79ddcdd80e03393bef33285dc2455a59267ba5a95dec21d9d22e04b2518e593fbf8e856c9f361516826e1141131657259 SHA512 09abd673152ffa2d9f88aea8d940f77e8fc16e8d4b3486f39b8ae56c6f57cf4e40cff8ba829ca568c6ca71d8b676dee394d0e2f36bbf9781f9e3a9ad106e201b
+DIST asm-ASM_8_0_1.tar.gz 1559218 BLAKE2B 2b1d039ccb569cf2574d55fb7f6d2c1535dfa3edfab785a6f0622a893cb5f83f21de2d6a737ac164914893cccdd1d87754284742cdf20f2bbd4f57843dd3b36d SHA512 0b0773c3970a426ebca489e68641c3ecf0cfd3b48cddba1b56ffe0e0ab95274b5a7bcb3ae8b5ade04dffdc366bd0fdd6fd0f0db59936d1994f88107e15c90932
+DIST asm-ASM_9_1.tar.gz 1614561 BLAKE2B f19efad14a7bce5dd7311682a2e6c8625816d1b97ed390652681f14d6d341f559fee152b70474566752a80ff2fcc7cb83fea91f7382f898a0725beba5c9c6ada SHA512 84eb7bc0c7119d3ab0ddd9f3bad640662d96235d365da5bd85031abbdfed371c9742a01817ddd022fd4fb447441f423e4f5126d12dcadf12fa9669cd86b34f18
diff --git a/dev-java/asm-commons/asm-commons-6.2.1.ebuild b/dev-java/asm-commons/asm-commons-6.2.1.ebuild
new file mode 100644
index 000000000000..47ceb6a135cd
--- /dev/null
+++ b/dev-java/asm-commons/asm-commons-6.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Bytecode manipulation framework for Java (Common class adaptors)"
+HOMEPAGE="http://asm.ow2.org"
+MY_P="ASM_${PV//./_}"
+SRC_URI="https://gitlab.ow2.org/asm/asm/-/archive/${MY_P}/asm-${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT=`ver_cut 1`
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+RESTRICT="test"
+
+CDEPEND="dev-java/asm-analysis:${SLOT} dev-java/asm-tree:${SLOT} dev-java/asm:${SLOT}"
+DEPEND=">=virtual/jdk-1.8
+${CDEPEND}
+"
+RDEPEND=">=virtual/jre-1.8
+${CDEPEND}
+"
+
+JAVA_GENTOO_CLASSPATH="asm-${SLOT} asm-tree-${SLOT} asm-analysis-${SLOT}"
+JAVA_SRC_DIR="asm-${MY_P}/${PN}/src/main/java"
diff --git a/dev-java/asm-commons/asm-commons-7.3.1.ebuild b/dev-java/asm-commons/asm-commons-7.3.1.ebuild
new file mode 100644
index 000000000000..47ceb6a135cd
--- /dev/null
+++ b/dev-java/asm-commons/asm-commons-7.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Bytecode manipulation framework for Java (Common class adaptors)"
+HOMEPAGE="http://asm.ow2.org"
+MY_P="ASM_${PV//./_}"
+SRC_URI="https://gitlab.ow2.org/asm/asm/-/archive/${MY_P}/asm-${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT=`ver_cut 1`
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+RESTRICT="test"
+
+CDEPEND="dev-java/asm-analysis:${SLOT} dev-java/asm-tree:${SLOT} dev-java/asm:${SLOT}"
+DEPEND=">=virtual/jdk-1.8
+${CDEPEND}
+"
+RDEPEND=">=virtual/jre-1.8
+${CDEPEND}
+"
+
+JAVA_GENTOO_CLASSPATH="asm-${SLOT} asm-tree-${SLOT} asm-analysis-${SLOT}"
+JAVA_SRC_DIR="asm-${MY_P}/${PN}/src/main/java"
diff --git a/dev-java/asm-commons/asm-commons-8.0.1.ebuild b/dev-java/asm-commons/asm-commons-8.0.1.ebuild
new file mode 100644
index 000000000000..47ceb6a135cd
--- /dev/null
+++ b/dev-java/asm-commons/asm-commons-8.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Bytecode manipulation framework for Java (Common class adaptors)"
+HOMEPAGE="http://asm.ow2.org"
+MY_P="ASM_${PV//./_}"
+SRC_URI="https://gitlab.ow2.org/asm/asm/-/archive/${MY_P}/asm-${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT=`ver_cut 1`
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+RESTRICT="test"
+
+CDEPEND="dev-java/asm-analysis:${SLOT} dev-java/asm-tree:${SLOT} dev-java/asm:${SLOT}"
+DEPEND=">=virtual/jdk-1.8
+${CDEPEND}
+"
+RDEPEND=">=virtual/jre-1.8
+${CDEPEND}
+"
+
+JAVA_GENTOO_CLASSPATH="asm-${SLOT} asm-tree-${SLOT} asm-analysis-${SLOT}"
+JAVA_SRC_DIR="asm-${MY_P}/${PN}/src/main/java"
diff --git a/dev-java/asm-commons/asm-commons-9.1.ebuild b/dev-java/asm-commons/asm-commons-9.1.ebuild
new file mode 100644
index 000000000000..47ceb6a135cd
--- /dev/null
+++ b/dev-java/asm-commons/asm-commons-9.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Bytecode manipulation framework for Java (Common class adaptors)"
+HOMEPAGE="http://asm.ow2.org"
+MY_P="ASM_${PV//./_}"
+SRC_URI="https://gitlab.ow2.org/asm/asm/-/archive/${MY_P}/asm-${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT=`ver_cut 1`
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+RESTRICT="test"
+
+CDEPEND="dev-java/asm-analysis:${SLOT} dev-java/asm-tree:${SLOT} dev-java/asm:${SLOT}"
+DEPEND=">=virtual/jdk-1.8
+${CDEPEND}
+"
+RDEPEND=">=virtual/jre-1.8
+${CDEPEND}
+"
+
+JAVA_GENTOO_CLASSPATH="asm-${SLOT} asm-tree-${SLOT} asm-analysis-${SLOT}"
+JAVA_SRC_DIR="asm-${MY_P}/${PN}/src/main/java"
diff --git a/dev-java/asm-commons/metadata.xml b/dev-java/asm-commons/metadata.xml
new file mode 100644
index 000000000000..f653390931e4
--- /dev/null
+++ b/dev-java/asm-commons/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>kaiboma06@gmail.com</email>
+ <name>Kaibo Ma</name>
+ </maintainer>
+ <longdescription>
+ ASM is a Java bytecode manipulation framework. It can be used to
+ dynamically generate stub classes or other proxy classes, directly in
+ binary form, or to dynamically modify classes at load time, i.e., just
+ before they are loaded into the Java Virtual Machine.
+
+ ASM offers similar functionalities as BCEL or SERP, but is much more
+ smaller (25KB instead of 350KB for BCEL and 150KB for SERP) and faster
+ than these tools (the overhead of a load time class transformation is of
+ the order of 60% with ASM, 700% or more with BCEL, and 1100% or more
+ with SERP). Indeed ASM was designed to be used in a dynamic way* and was
+ therefore designed and implemented to be as small and as fast as
+ possible.
+ </longdescription>
+</pkgmetadata>