summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-01-16 22:36:47 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-01-17 00:01:14 +0000
commitc9c3c6462b3c94af2c1255167f625826d238c15c (patch)
tree58c20fcbab65240e723a1567fce411516ebcd531 /dev-java/assertj-core/assertj-core-2.3.0.ebuild
parentsci-libs/getdata: Add and make dependencies explicit (diff)
downloadgentoo-c9c3c6462b3c94af2c1255167f625826d238c15c.tar.gz
gentoo-c9c3c6462b3c94af2c1255167f625826d238c15c.tar.bz2
gentoo-c9c3c6462b3c94af2c1255167f625826d238c15c.zip
dev-java/assertj-core: New package, needed by latest testng's tests
No tests on this one for now due to missing dependencies. This isn't the newest version but I don't know whether 3.x is compatible and it also requires Java 8, which might be inconvenient at present. Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/assertj-core/assertj-core-2.3.0.ebuild')
-rw-r--r--dev-java/assertj-core/assertj-core-2.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/assertj-core/assertj-core-2.3.0.ebuild b/dev-java/assertj-core/assertj-core-2.3.0.ebuild
new file mode 100644
index 000000000000..949ca8869b3e
--- /dev/null
+++ b/dev-java/assertj-core/assertj-core-2.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java library that provides a fluent interface for writing assertions"
+HOMEPAGE="http://joel-costigliola.github.io/assertj/"
+SRC_URI="https://github.com/joel-costigliola/${PN}/archive/${P}.tar.gz"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="2"
+
+CDEPEND="dev-java/cglib:3
+ dev-java/junit:4"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.7"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.7"
+
+S="${WORKDIR}/${PN}-${P}"
+JAVA_SRC_DIR="src/main/java"
+JAVA_GENTOO_CLASSPATH="cglib-3,junit-4"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc {CONTRIBUTING,README}.md
+}