summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/avalon-logkit/avalon-logkit-1.2.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/avalon-logkit/avalon-logkit-1.2.2-r1.ebuild')
-rw-r--r--dev-java/avalon-logkit/avalon-logkit-1.2.2-r1.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/dev-java/avalon-logkit/avalon-logkit-1.2.2-r1.ebuild b/dev-java/avalon-logkit/avalon-logkit-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..651c72a0bb95
--- /dev/null
+++ b/dev-java/avalon-logkit/avalon-logkit-1.2.2-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="An easy-to-use Java logging toolkit designed for secure, performance-oriented logging"
+HOMEPAGE="http://avalon.apache.org/"
+SRC_URI="mirror://apache/avalon/logkit/source/logkit-${PV}-src.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="1.2"
+IUSE=""
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+
+COMMON_DEP="
+ dev-java/avalon-framework:4.1
+ dev-java/log4j:0
+ java-virtuals/jaf:0
+ java-virtuals/javamail:0
+ java-virtuals/jms:0
+ java-virtuals/servlet-api:2.5"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.4"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4
+ test? ( dev-java/junit:4 )"
+
+S="${WORKDIR}/logkit-${PV}-dev"
+SRC_DIR="${S}/src/java"
+JAVADOC_DIR="${S}/javadoc"
+
+java_prepare() {
+ epatch "${FILESDIR}/${P}-java7.patch"
+}
+
+src_compile() {
+ mkdir classes || die "Could not create compile output dir"
+
+ ejavac \
+ -encoding "ISO-8859-1" \
+ -classpath $(java-pkg_getjars jaf,javamail,jms,log4j,servlet-api-2.5,avalon-framework-4.1) \
+ -d classes $(find "${SRC_DIR}" -name "*.java") \
+ || die "Compilation failed"
+
+ jar -cf "${S}/${PN}.jar" -C classes . || die "Could not create jar"
+
+ #Generate javadoc
+ if use doc ; then
+ mkdir "${JAVADOC_DIR}" || die "Could not create javadoc dir"
+ cd "${SRC_DIR}"
+ javadoc \
+ -encoding "ISO-8859-1" \
+ -sourcepath "${SRC_DIR}" \
+ -classpath $(java-pkg_getjars jaf,javamail,jms,log4j,servlet-api-2.5,avalon-framework-4.1) \
+ -source "${JAVA_VERSION}" \
+ -d "${JAVADOC_DIR}" \
+ $(find "org/apache/log" -type d | tr '/' '.') \
+ || die "Could not create javadoc"
+ fi
+}
+
+src_test() {
+ mkdir test-classes || die "Unable to make dir"
+ local TESTJAR="avalon-logkit-test.jar"
+
+ ejavac \
+ -encoding "ISO-8859-1" \
+ -classpath "avalon-logkit.jar:$(java-config -p junit-4)" \
+ -d test-classes \
+ $(find src/test -name '*.java')
+
+ jar -cf "${TESTJAR}" -C test-classes .
+
+ java -cp "avalon-logkit.jar:${TESTJAR}:$(java-config -p junit:4)" \
+ org.junit.runner.JUnitCore org.apache.log.format.test.FormatterTestCase \
+ org.apache.log.output.test.RevolvingFileStrategyTestCase \
+ org.apache.log.output.test.OutputTargetTestCase \
+ org.apache.log.output.test.DBTargetTestCase \
+ org.apache.log.util.test.UtilTestCase \
+ org.apache.log.test.LoggerListenerTestCase \
+ org.apache.log.test.WrappingTargetTestCase \
+ org.apache.log.test.InheritanceTestCase
+}
+
+src_install() {
+ java-pkg_dojar "${PN}.jar"
+ use doc && java-pkg_dojavadoc "${JAVADOC_DIR}"
+ use source && java-pkg_dosrc "${SRC_DIR}/*"
+}