summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-04-28 19:09:00 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-28 19:09:00 +0200
commit9e5cb2febf34c7b26d0b38397fefc98bd6bb613c (patch)
treeb5a29b86a9d7993825f979b9a538e60b06b2892c /dev-java/bytelist
parentprofiles/package.mask: dev-java/jisp last-rite (diff)
downloadgentoo-9e5cb2febf34c7b26d0b38397fefc98bd6bb613c.tar.gz
gentoo-9e5cb2febf34c7b26d0b38397fefc98bd6bb613c.tar.bz2
gentoo-9e5cb2febf34c7b26d0b38397fefc98bd6bb613c.zip
dev-java/bytelist: removed obsolete 1.0.10
Bug: https://bugs.gentoo.org/785298 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/bytelist')
-rw-r--r--dev-java/bytelist/Manifest1
-rw-r--r--dev-java/bytelist/bytelist-1.0.10.ebuild49
-rw-r--r--dev-java/bytelist/files/maven-build.xml219
3 files changed, 0 insertions, 269 deletions
diff --git a/dev-java/bytelist/Manifest b/dev-java/bytelist/Manifest
index 23649777ad6a..a7640c923926 100644
--- a/dev-java/bytelist/Manifest
+++ b/dev-java/bytelist/Manifest
@@ -1,2 +1 @@
-DIST bytelist-1.0.10.tar.gz 15619 BLAKE2B d715949e9d78201c2fbc97a6c055630b83db4989108f7fb5f68d09cc461b4bf8f30f7ffb0ad66166aa13f23a50a832e12d721ffa2a72206348db0f4070fad941 SHA512 fb522a43d5cac8a4804f64caa38fb9ab793a0f0688a69987f3be6f2245a4a2c9739a0d807f88be947c0bd7f908c069a2f8092cc4d5314c3fddb6541d9db70f7c
DIST bytelist-1.0.15-sources.tar.gz 50512 BLAKE2B f17094ac4ef8ea68d48b05589b9fe3b8a90033dbc33992d0ebbcf70851c6877e20dcbe68f2e505e62301346653519833318d2c671bea9d6914d9f017610204f7 SHA512 1575a97229db7a7b99abd4fc74e713f79cd9bca4b7ffa13ba52607d84d5f7af8863c45dfd65dd32e12b03feb659808cf2f07ea494c87ca496061ab00280a40f4
diff --git a/dev-java/bytelist/bytelist-1.0.10.ebuild b/dev-java/bytelist/bytelist-1.0.10.ebuild
deleted file mode 100644
index eb1aa2d3d034..000000000000
--- a/dev-java/bytelist/bytelist-1.0.10.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="JRuby support library"
-HOMEPAGE="https://github.com/codehaus"
-SRC_URI="https://github.com/jruby/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="|| ( CPL-1.0 GPL-2 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
-
-COMMON_DEP="dev-java/jcodings:0"
-
-RDEPEND="${COMMON_DEP}
- >=virtual/jre-1.5"
-
-DEPEND="${COMMON_DEP}
- >=virtual/jdk-1.5
- test? ( dev-java/ant-junit:0 )"
-
-src_unpack() {
- default
- mv "${WORKDIR}"/jruby-${PN}-* "${WORKDIR}"/${P} || die
-}
-
-java_prepare() {
- cp "${FILESDIR}"/maven-build.xml build.xml || die
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-EANT_GENTOO_CLASSPATH="jcodings"
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_dojar target/${PN}.jar
-
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/*
-}
diff --git a/dev-java/bytelist/files/maven-build.xml b/dev-java/bytelist/files/maven-build.xml
deleted file mode 100644
index ee880775a409..000000000000
--- a/dev-java/bytelist/files/maven-build.xml
+++ /dev/null
@@ -1,219 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<project name="bytelist-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="bytelist"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="test"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath">
- </path>
- <path id="build.test.classpath">
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" depends="get-deps" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.5"
- verbose="false"
- fork="false"
- source="1.5">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.5"
- verbose="false"
- fork="false"
- source="1.5">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- linksource="false"
- breakiterator="false"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- manifest="MANIFEST.MF"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
- <target name="get-deps"
- depends="test-offline"
- description="Download all dependencies"
- unless="maven.mode.offline">
- </target>
-
-</project>