summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-08-29 20:40:21 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-09-01 00:12:26 +0200
commit6130090d87df128f3b9a6ce0740210a2e5d0d240 (patch)
tree66e429765ac33a39b70e2b9ef6b93d09f160272b /dev-java/classmate/classmate-1.1.0.ebuild
parentdev-java/gnu-jaf: version bump. (diff)
downloadgentoo-6130090d87df128f3b9a6ce0740210a2e5d0d240.tar.gz
gentoo-6130090d87df128f3b9a6ce0740210a2e5d0d240.tar.bz2
gentoo-6130090d87df128f3b9a6ce0740210a2e5d0d240.zip
dev-java/classmate: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-java/classmate/classmate-1.1.0.ebuild')
-rw-r--r--dev-java/classmate/classmate-1.1.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/classmate/classmate-1.1.0.ebuild b/dev-java/classmate/classmate-1.1.0.ebuild
new file mode 100644
index 000000000000..65b7a55fc95a
--- /dev/null
+++ b/dev-java/classmate/classmate-1.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Zero-dependency Java library for accurately introspecting type information"
+HOMEPAGE="https://github.com/cowtowncoder/java-classmate/"
+SRC_URI="https://github.com/cowtowncoder/java-classmate/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ test? ( dev-java/junit:4 )"
+
+S="${WORKDIR}/java-${PN}-${P}"
+
+JAVA_SRC_DIR="src/main/java"
+
+# This one test is buggy.
+JAVA_RM_FILES=(
+ src/test/java/com/fasterxml/classmate/AnnotationsTest.java
+)
+
+src_prepare() {
+ default
+ rm -v pom.xml \
+ src/test/java/com/fasterxml/classmate/AnnotationsTest.java || die
+}
+
+src_test() {
+ testcp="${S}/${PN}.jar:$(java-pkg_getjars junit-4):target/tests"
+
+ mkdir target/tests || die
+ ejavac -cp "${testcp}" -d target/tests $(find src/test/java -name "*.java")
+
+ tests=$(find target/tests -name "*Test.class" -not -name "BaseTest.class" \
+ | sed -e 's/target\/tests\///g' -e "s/\.class//" -e "s/\//./g" \
+ | grep -vP '\$');
+ ejunit4 -cp "${testcp}" ${tests}
+}