summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-08-21 13:11:50 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-08-21 13:22:39 +0000
commit5f9fec1903d2cd70d1ec64bd4f9ea584405a52ea (patch)
treeaaea6309bea253cf6c7e8f76b2bc0325ad791f33 /dev-java/classmate
parentdev-java/cdi-api: Stable for amd64+x86. (diff)
downloadgentoo-5f9fec1903d2cd70d1ec64bd4f9ea584405a52ea.tar.gz
gentoo-5f9fec1903d2cd70d1ec64bd4f9ea584405a52ea.tar.bz2
gentoo-5f9fec1903d2cd70d1ec64bd4f9ea584405a52ea.zip
dev-java/classmate: Remove a buggy test.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/classmate')
-rw-r--r--dev-java/classmate/classmate-0.9.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/classmate/classmate-0.9.0-r1.ebuild b/dev-java/classmate/classmate-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..60a636f42fd1
--- /dev/null
+++ b/dev-java/classmate/classmate-0.9.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-pkg-simple vcs-snapshot
+
+DESCRIPTION="Library for introspecting generic type information of types, member/static methods, fields"
+HOMEPAGE="https://github.com/cowtowncoder/java-classmate/"
+SRC_URI="https://github.com/cowtowncoder/java-classmate/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+ test? ( dev-java/junit:4 )"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src/main/java"
+
+# This one test is buggy.
+JAVA_RM_FILES=(
+ src/test/java/com/fasterxml/classmate/AnnotationsTest.java
+)
+
+java_prepare() {
+ rm pom.xml || die
+}
+
+src_test() {
+ testcp="${S}/${PN}.jar:$(java-pkg_getjars junit-4):target/tests"
+
+ mkdir target/tests || die
+ ejavac -cp "${testcp}" -d target/tests $(find src/test/java -name "*.java")
+
+ tests=$(find target/tests -name "*Test.class" -not -name "BaseTest.class" \
+ | sed -e 's/target\/tests\///g' -e "s/\.class//" -e "s/\//./g" \
+ | grep -vP '\$');
+ ejunit4 -cp "${testcp}" ${tests}
+}