summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-chain/commons-chain-1.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-chain/commons-chain-1.2.ebuild')
-rw-r--r--dev-java/commons-chain/commons-chain-1.2.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-java/commons-chain/commons-chain-1.2.ebuild b/dev-java/commons-chain/commons-chain-1.2.ebuild
new file mode 100644
index 000000000000..39cccd08e661
--- /dev/null
+++ b/dev-java/commons-chain/commons-chain-1.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${P}-src"
+DESCRIPTION="API exposing the Chain of Responsability design pattern - by the ASF"
+HOMEPAGE="http://commons.apache.org/proper/commons-chain/"
+SRC_URI="mirror://apache/commons/chain/source/${MY_P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="1.2"
+KEYWORDS="~amd64 ~x86"
+
+# Too many missing imports from javax.servlet.* which cause the
+# "compile-tests" target to fail compiling.
+# I gave up on it after wasting nearly half a day.
+RESTRICT="test"
+
+IUSE=""
+
+CDEPEND="dev-java/commons-digester:0
+ dev-java/mojarra:2.2
+ dev-java/portletapi:2.0
+ dev-java/commons-logging:0
+ java-virtuals/servlet-api:3.0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="
+ commons-logging
+ commons-digester
+ portletapi-2.0
+ mojarra-2.2
+ servlet-api-3.0
+"
+
+EANT_BUILD_TARGET="package"
+EANT_BUILD_XML="build.xml"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml
+}
+
+src_install() {
+ java-pkg_newjar "${S}"/target/${P}.jar commons-chain.jar
+
+ if use doc; then
+ java-pkg_dohtml -r "${S}"/target/site/apidocs/
+ fi
+
+ if use source; then
+ java-pkg_dosrc "${S}"/src/*
+ fi
+}