summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-compress
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-compress')
-rw-r--r--dev-java/commons-compress/Manifest2
-rw-r--r--dev-java/commons-compress/commons-compress-1.4.1.ebuild56
-rw-r--r--dev-java/commons-compress/commons-compress-1.8.1-r1.ebuild56
-rw-r--r--dev-java/commons-compress/commons-compress-1.8.1.ebuild56
-rw-r--r--dev-java/commons-compress/files/MANIFEST.MF24
-rw-r--r--dev-java/commons-compress/files/build.xml269
-rw-r--r--dev-java/commons-compress/metadata.xml9
7 files changed, 472 insertions, 0 deletions
diff --git a/dev-java/commons-compress/Manifest b/dev-java/commons-compress/Manifest
new file mode 100644
index 000000000000..99045263e539
--- /dev/null
+++ b/dev-java/commons-compress/Manifest
@@ -0,0 +1,2 @@
+DIST commons-compress-1.4.1-src.tar.gz 3228776 SHA256 b4f34aa03df917b785479e147381eea86c5c17e9067ddf8c27301ff6cd0aa91c SHA512 e1d327f084a79924938698ae16fa6edaaa73072b083109bbd8ccaa636268c05c387e7c2117b5df8f6b91b143495add9cc7da17c1bd3c989f91c910a9d68f6bdb WHIRLPOOL 50565e7342fa363814ed2f347d1daa1ee59dd28cefcd9e494850edcf47899b8684312996dd60b90236a4f2aacce8a920ace37cca5d1d22ad9f63f6696c8e7452
+DIST commons-compress-1.8.1-src.tar.gz 8476056 SHA256 aa1221643331d9de5c8155b032c7fde23fc8cf3d962155092de89c44d4978412 SHA512 4e4f9633cc3c470970a8da41344a819ff63430a46e219e93896dbe2374738349f78942cff93ad8d348599cfc2dd7d014ae4ff3b09d76a924bb11ca1c4a2c05ea WHIRLPOOL 2d7f3230f47186a72b4b31efd10c5dfd68488d263e26d97b6e715b2b2eab3e22ae3e5946d232ca014aa2a3d14f3abf87ce97bf2e70c7c06788c4093df4156aef
diff --git a/dev-java/commons-compress/commons-compress-1.4.1.ebuild b/dev-java/commons-compress/commons-compress-1.4.1.ebuild
new file mode 100644
index 000000000000..12176cdfe021
--- /dev/null
+++ b/dev-java/commons-compress/commons-compress-1.4.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Commons Compress defines an API for working with ar, cpio, tar, zip, gzip and bzip2 files"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="dev-java/xz-java"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEPEND}
+ test? ( dev-java/junit:4
+ dev-java/hamcrest-core
+ dev-java/ant-junit:0 )"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ANT_BSFIX_EXTRA_ARGS="--maven-cleaning"
+EANT_GENTOO_CLASSPATH="xz-java"
+EANT_BUILD_TARGET="compile package"
+EANT_TEST_GENTOO_CLASSPATH="junit-4 hamcrest-core xz-java"
+
+java_prepare() {
+ cp "${FILESDIR}"/build.xml . || die "Failed to copy build.xml"
+
+ # osgi stuff mvn ant:ant doesn't handle
+ mkdir -p target/osgi || die "Failed to create target dir"
+ cp "${FILESDIR}"/MANIFEST.MF target/osgi/ || die "Failed to copy manifest"
+
+ if ! use test; then
+ find -name "*.jar" -delete || die "Failed to remove test resources"
+ fi
+}
+
+src_test() {
+ EANT_TEST_TARGET="compile-tests test"
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${PN}-1.1.jar
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/commons-compress/commons-compress-1.8.1-r1.ebuild b/dev-java/commons-compress/commons-compress-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..ce1dd1b3894c
--- /dev/null
+++ b/dev-java/commons-compress/commons-compress-1.8.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Commons Compress defines an API for working with ar, cpio, tar, zip, gzip and bzip2 files"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="dev-java/xz-java"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEPEND}
+ test? ( dev-java/junit:4
+ dev-java/hamcrest-core:1.3
+ dev-java/ant-junit:0 )"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ANT_BSFIX_EXTRA_ARGS="--maven-cleaning"
+EANT_GENTOO_CLASSPATH="xz-java"
+EANT_BUILD_TARGET="compile package"
+EANT_TEST_GENTOO_CLASSPATH="junit-4 hamcrest-core-1.3 xz-java"
+
+java_prepare() {
+ cp "${FILESDIR}"/build.xml . || die "Failed to copy build.xml"
+
+ # osgi stuff mvn ant:ant doesn't handle
+ mkdir -p target/osgi || die "Failed to create target dir"
+ cp "${FILESDIR}"/MANIFEST.MF target/osgi/ || die "Failed to copy manifest"
+
+ if ! use test; then
+ find -name "*.jar" -delete || die "Failed to remove test resources"
+ fi
+}
+
+src_test() {
+ EANT_TEST_TARGET="compile-tests test"
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${PN}-1.1.jar
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/commons-compress/commons-compress-1.8.1.ebuild b/dev-java/commons-compress/commons-compress-1.8.1.ebuild
new file mode 100644
index 000000000000..d52a6db08966
--- /dev/null
+++ b/dev-java/commons-compress/commons-compress-1.8.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Commons Compress defines an API for working with ar, cpio, tar, zip, gzip and bzip2 files"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-java/xz-java"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEPEND}
+ test? ( dev-java/junit:4
+ dev-java/hamcrest-core
+ dev-java/ant-junit:0 )"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ANT_BSFIX_EXTRA_ARGS="--maven-cleaning"
+EANT_GENTOO_CLASSPATH="xz-java"
+EANT_BUILD_TARGET="compile package"
+EANT_TEST_GENTOO_CLASSPATH="junit-4 hamcrest-core xz-java"
+
+java_prepare() {
+ cp "${FILESDIR}"/build.xml . || die "Failed to copy build.xml"
+
+ # osgi stuff mvn ant:ant doesn't handle
+ mkdir -p target/osgi || die "Failed to create target dir"
+ cp "${FILESDIR}"/MANIFEST.MF target/osgi/ || die "Failed to copy manifest"
+
+ if ! use test; then
+ find -name "*.jar" -delete || die "Failed to remove test resources"
+ fi
+}
+
+src_test() {
+ EANT_TEST_TARGET="compile-tests test"
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${PN}-1.1.jar
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/commons-compress/files/MANIFEST.MF b/dev-java/commons-compress/files/MANIFEST.MF
new file mode 100644
index 000000000000..ab91795ef624
--- /dev/null
+++ b/dev-java/commons-compress/files/MANIFEST.MF
@@ -0,0 +1,24 @@
+Manifest-Version: 1.0
+Export-Package: org.apache.commons.compress.changes;version="1.1",org.
+ apache.commons.compress.archivers.ar;version="1.1",org.apache.commons
+ .compress.archivers.jar;version="1.1",org.apache.commons.compress.arc
+ hivers.cpio;version="1.1",org.apache.commons.compress.archivers.zip;v
+ ersion="1.1",org.apache.commons.compress.archivers;version="1.1",org.
+ apache.commons.compress.archivers.tar;version="1.1",org.apache.common
+ s.compress.compressors.bzip2;version="1.1",org.apache.commons.compres
+ s.compressors;version="1.1",org.apache.commons.compress.utils;version
+ ="1.1",org.apache.commons.compress.compressors.gzip;version="1.1"
+Tool: Bnd-0.0.255
+Bundle-Name: Commons Compress
+Created-By: 1.7.0-ea (Oracle Corporation)
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 1.1
+Bnd-LastModified: 1311506267618
+Bundle-ManifestVersion: 2
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-Description: Commons Compress defines an API for working with c
+ ompression and archive formats. These include: bzip2, gzip and ar, c
+ pio, jar, tar, zip.
+Bundle-SymbolicName: org.apache.commons.compress
+Bundle-DocURL: http://commons.apache.org/compress/
+
diff --git a/dev-java/commons-compress/files/build.xml b/dev-java/commons-compress/files/build.xml
new file mode 100644
index 000000000000..f42093f83866
--- /dev/null
+++ b/dev-java/commons-compress/files/build.xml
@@ -0,0 +1,269 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 7/24/11 12:42 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="commons-compress-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="commons-compress-1.1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="junit.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.4"
+ verbose="false"
+ fork="false"
+ source="1.4">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.0}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.4"
+ verbose="false"
+ fork="false"
+ source="1.4">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ <exclude name="**/*Abstract*TestCase.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ <exclude name="**/*Abstract*TestCase.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="iso-8859-1"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.4"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://java.sun.com/javase/6/docs/api/"/>
+ <tag name="Immutable"
+ description="This class is immutable"/>
+ <tag name="NotThreadSafe"
+ description="This class is not thread-safe"/>
+ <tag name="ThreadSafe"
+ description="This class is thread-safe"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="target/osgi/MANIFEST.MF"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/3.8.2"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/3.8.2/junit-3.8.2.jar"
+ dest="${maven.repo.local}/junit/junit/3.8.2/junit-3.8.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo1.maven.org/maven2/junit/junit/3.8.2/junit-3.8.2.jar"
+ dest="${maven.repo.local}/junit/junit/3.8.2/junit-3.8.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/commons-compress/metadata.xml b/dev-java/commons-compress/metadata.xml
new file mode 100644
index 000000000000..fed3658eec53
--- /dev/null
+++ b/dev-java/commons-compress/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tommy@gentoo.org</email>
+ <name>Thomas Sachau (Tommy[D])</name>
+ </maintainer>
+</pkgmetadata>
+