summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-dbutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-dbutils')
-rw-r--r--dev-java/commons-dbutils/Manifest1
-rw-r--r--dev-java/commons-dbutils/commons-dbutils-1.1.ebuild31
-rw-r--r--dev-java/commons-dbutils/files/1.1-tests.patch12
-rw-r--r--dev-java/commons-dbutils/metadata.xml5
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-java/commons-dbutils/Manifest b/dev-java/commons-dbutils/Manifest
new file mode 100644
index 000000000000..4be4cdd0ba94
--- /dev/null
+++ b/dev-java/commons-dbutils/Manifest
@@ -0,0 +1 @@
+DIST commons-dbutils-1.1-src.tar.gz 60062 SHA256 645f79936bb90c5ed02fd4d1ddbc15b23e22a468ab0df22771f2b78fe8d49a59 SHA512 03859d0ddc65b1f0254f71e9de371f131a81dc839de6bea938a0547b63759d18a9e957f44ac887b7ae9ea85ee3aeea90ffd8f03069c670ec7b700fe8b6e45fe2 WHIRLPOOL b4b3e670b30101657c0d57fcf33993cdca89838135f147b54c63ac4bbced6fe1ed1218af36e95bec60e856c73a9d47fbfc1eecdbbd55dd7e476f6883fd94f3fd
diff --git a/dev-java/commons-dbutils/commons-dbutils-1.1.ebuild b/dev-java/commons-dbutils/commons-dbutils-1.1.ebuild
new file mode 100644
index 000000000000..3a63ce873b14
--- /dev/null
+++ b/dev-java/commons-dbutils/commons-dbutils-1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit base java-pkg-2 java-ant-2
+
+DESCRIPTION="A small set of classes designed to make working with JDBC easier"
+HOMEPAGE="http://commons.apache.org/dbutils/"
+SRC_URI="mirror://apache/commons/dbutils/source/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${P}-src"
+
+PATCHES=( "${FILESDIR}/1.1-tests.patch" )
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-dbutils/files/1.1-tests.patch b/dev-java/commons-dbutils/files/1.1-tests.patch
new file mode 100644
index 000000000000..a2036d4180e1
--- /dev/null
+++ b/dev-java/commons-dbutils/files/1.1-tests.patch
@@ -0,0 +1,12 @@
+diff -ur commons-dbutils-1.1-src.old/build.xml commons-dbutils-1.1-src/build.xml
+--- commons-dbutils-1.1-src.old/build.xml 2008-02-13 22:18:49.000000000 +0200
++++ commons-dbutils-1.1-src/build.xml 2008-02-13 22:18:59.000000000 +0200
+@@ -62,7 +62,7 @@
+ </classpath>
+ </javac>
+ </target>
+- <target name="jar" description="o Create the jar" depends="compile,test">
++ <target name="jar" description="o Create the jar" depends="compile">
+ <jar jarfile="target/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}">
+ </jar>
+ </target>
diff --git a/dev-java/commons-dbutils/metadata.xml b/dev-java/commons-dbutils/metadata.xml
new file mode 100644
index 000000000000..250f2d1940ea
--- /dev/null
+++ b/dev-java/commons-dbutils/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>