summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/glassfish-deployment-api
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/glassfish-deployment-api')
-rw-r--r--dev-java/glassfish-deployment-api/Manifest1
-rw-r--r--dev-java/glassfish-deployment-api/files/glassfish-deployment-api-1.2-build.xml.patch26
-rw-r--r--dev-java/glassfish-deployment-api/glassfish-deployment-api-1.2.ebuild38
-rw-r--r--dev-java/glassfish-deployment-api/metadata.xml5
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-java/glassfish-deployment-api/Manifest b/dev-java/glassfish-deployment-api/Manifest
new file mode 100644
index 000000000000..493f09a69f36
--- /dev/null
+++ b/dev-java/glassfish-deployment-api/Manifest
@@ -0,0 +1 @@
+DIST glassfish-v2ur2-b04-src.zip 39817113 SHA256 b554e618ed8edddd8f77de15a800b7d374edbfe1814196125c1e9ee7634ba388 SHA512 4ddf75ad1b81cfb8fc0b772fc75f9a81d74b6239282770d5da0ed70a7cd8b5fca2fd8c95782a2946ed054b43ee8e17edaf47d79c749e89280131bf1d15b1dcf8 WHIRLPOOL c3796120a85b2e370cb9fced56c166a554cd40ee2278c819ee6fa4eadce325373f1d2369cad77746f6e5b871c075d16adfdc9dbfb1bd20194e0f19e6ef0f0719
diff --git a/dev-java/glassfish-deployment-api/files/glassfish-deployment-api-1.2-build.xml.patch b/dev-java/glassfish-deployment-api/files/glassfish-deployment-api-1.2-build.xml.patch
new file mode 100644
index 000000000000..155b6af84b95
--- /dev/null
+++ b/dev-java/glassfish-deployment-api/files/glassfish-deployment-api-1.2-build.xml.patch
@@ -0,0 +1,26 @@
+diff -Nru deployment-api.vanilla/build.xml deployment-api/build.xml
+--- deployment-api.vanilla/build.xml 2009-05-09 15:54:02.000000000 +0100
++++ deployment-api/build.xml 2009-05-09 15:54:44.000000000 +0100
+@@ -70,12 +70,7 @@
+ description="Compile javax/enterprise/deploy sources">
+
+ <javac srcdir="${src.dir}"
+- destdir="${component.classes.dir}"
+- debug="${javac.debug}"
+- optimize="${javac.optimize}"
+- source="${javac.source}"
+- deprecation="${javac.deprecation}"
+- failonerror="true">
++ destdir="${component.classes.dir}">
+ <include name="javax/enterprise/deploy/**"/>
+ </javac>
+ </target>
+@@ -89,7 +84,7 @@
+ includes="**/LocalStrings.properties"/>
+ </copy>
+
+- <jar jarfile="${javaee.jar}" update="yes">
++ <jar jarfile="deployment-api.jar" update="yes">
+ <fileset dir="${component.classes.dir}">
+ <include name="javax/enterprise/deploy/**/*.class"/>
+ <include name="javax/enterprise/deploy/**/*.properties"/>
diff --git a/dev-java/glassfish-deployment-api/glassfish-deployment-api-1.2.ebuild b/dev-java/glassfish-deployment-api/glassfish-deployment-api-1.2.ebuild
new file mode 100644
index 000000000000..137390c02802
--- /dev/null
+++ b/dev-java/glassfish-deployment-api/glassfish-deployment-api-1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_PV=${PV/./_}
+
+DESCRIPTION="J2EE Application Deployment Specification"
+HOMEPAGE="https://glassfish.dev.java.net/"
+LICENSE="|| ( CDDL GPL-2 )"
+SLOT="1.2"
+
+KEYWORDS="amd64 ppc x86"
+
+GLASSFISH_MAJOR="v2ur2"
+GLASSFISH_MINOR="b04"
+SRC_URI="http://download.java.net/javaee5/${GLASSFISH_MAJOR}/promoted/source/glassfish-${GLASSFISH_MAJOR}-${GLASSFISH_MINOR}-src.zip"
+
+IUSE=""
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/glassfish/deployment-api/"
+EANT_BUILD_TARGET="all"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+}
+
+src_install() {
+ java-pkg_newjar "deployment-api.jar"
+ use source && java-pkg_dosrc src/java/javax
+}
diff --git a/dev-java/glassfish-deployment-api/metadata.xml b/dev-java/glassfish-deployment-api/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/glassfish-deployment-api/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>