summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.1-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.1-r3.ebuild')
-rw-r--r--dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.1-r3.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.1-r3.ebuild b/dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.1-r3.ebuild
new file mode 100644
index 000000000000..26c4156c60e0
--- /dev/null
+++ b/dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.1-r3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="inetlib"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Network extensions library for GNU classpath and classpathx"
+HOMEPAGE="http://www.gnu.org/software/classpath/"
+SRC_URI="mirror://gnu/classpath/${MY_P}.tar.gz"
+LICENSE="GPL-2-with-linking-exception"
+SLOT="1.1"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/gnu-crypto-2.0.1"
+DEPEND=">=virtual/jdk-1.3
+ ${RDEPEND}"
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-jdk15.patch"
+
+ mkdir ext && cd ext
+ java-pkg_jar-from gnu-crypto
+ # fake jar to shut build system up, jsse is part of JDK's classpath already
+ ln -s javax-security.jar jsse.jar
+}
+
+src_compile() {
+ econf \
+ --enable-smtp \
+ --enable-imap \
+ --enable-pop3 \
+ --enable-nntp \
+ --enable-ftp \
+ --enable-gopher \
+ --with-jsse-jar="${S}"/ext \
+ --with-javax-security-jar="${S}"/ext \
+ || die
+ # https://bugs.gentoo.org/show_bug.cgi?id=179897
+ emake JAVACFLAGS="${JAVACFLAGS}" -j1 || die
+ if use doc ; then
+ emake -j1 javadoc || die
+ fi
+}
+
+src_install() {
+ einstall || die
+ rm -rf "${D}"/usr/share/java
+ java-pkg_dojar inetlib.jar
+ use doc && java-pkg_dojavadoc docs
+ dodoc AUTHORS NEWS README || die
+}