summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/gnu-javamail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/gnu-javamail')
-rw-r--r--dev-java/gnu-javamail/Manifest1
-rw-r--r--dev-java/gnu-javamail/gnu-javamail-1.0-r2.ebuild55
-rw-r--r--dev-java/gnu-javamail/metadata.xml27
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-java/gnu-javamail/Manifest b/dev-java/gnu-javamail/Manifest
new file mode 100644
index 000000000000..03c01800bac3
--- /dev/null
+++ b/dev-java/gnu-javamail/Manifest
@@ -0,0 +1 @@
+DIST mail-1.0.tar.gz 707084 SHA256 0dcbf6b24ea1f0a47a4aff15060dda19349d8bea7025a6e7d2249969afb7099e SHA512 14513b577a312c4c3ba994db02ca561614f64d532baf07a3f58d97d8a8e129d83ed29a835b079131c1789c584b851188ae1450a531b6e5a544513c219bc37f09 WHIRLPOOL 6001858a0bb73bbb5ea855fc781ee09ed3773c7de67fc4cfed7fd6b34ea3bced42c78900de022996a2ae34651aa7884cb2e6a69d25e5fb2ade7415707a51913b
diff --git a/dev-java/gnu-javamail/gnu-javamail-1.0-r2.ebuild b/dev-java/gnu-javamail/gnu-javamail-1.0-r2.ebuild
new file mode 100644
index 000000000000..f30e319ebc81
--- /dev/null
+++ b/dev-java/gnu-javamail/gnu-javamail-1.0-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2
+
+MY_PN="mail"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="GNU implementation of the Javamail API"
+HOMEPAGE="http://www.gnu.org/software/classpathx/javamail/"
+SRC_URI="mirror://gnu/classpathx/${MY_P}.tar.gz"
+LICENSE="GPL-2-with-linking-exception"
+SLOT="1"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+RDEPEND=">=virtual/jre-1.4
+ =dev-java/gnu-jaf-1*
+ =dev-java/gnu-classpath-inetlib-1.0*
+ !<=dev-java/mx4j-3.0.1
+ !<=dev-java/mx4j-3.0.1-r2"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+# TODO: Re-enable jikes support (see bug #89711)
+
+src_compile() {
+ local activation=$(dirname $(java-pkg_getjar gnu-jaf-1 activation.jar))
+ local inetlib=$(dirname $(java-pkg_getjar gnu-classpath-inetlib-1.0 inetlib.jar))
+
+ econf \
+ --with-activation-jar=${activation} \
+ --with-inetlib-jar=${inetlib} \
+ --enable-smtp \
+ --enable-imap \
+ --enable-pop3 \
+ --enable-nntp \
+ --enable-mbox \
+ --enable-maildir \
+ || die "failed to configure"
+
+ emake JAVACFLAGS="${JAVACFLAGS}" || die "failed to compile"
+
+ if use doc; then
+ emake javadoc || die "failed to generate javadoc"
+ fi
+}
+
+src_install() {
+ java-pkg_dojar gnumail-providers.jar
+ java-pkg_newjar gnumail.jar mail.jar
+ dodoc AUTHORS ChangeLog NEWS README README.*
+ use doc && java-pkg_dojavadoc docs
+}
diff --git a/dev-java/gnu-javamail/metadata.xml b/dev-java/gnu-javamail/metadata.xml
new file mode 100644
index 000000000000..a2c2a21734d6
--- /dev/null
+++ b/dev-java/gnu-javamail/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+GNU JavaMail is a free implementation of the JavaMail API specification,
+version 1.3. All the code has been written from scratch without
+reference to Sun's code, which allows GNU JavaMail to be used on a
+completely free operating system such as GNU/Linux or the Hurd. The code
+is optimized to work with free Java implementations, nothing prevents it
+from being used with any compliant JVM.
+
+GNU JavaMail provides a protocol-independent framework for building mail
+client applications in Java. The API itself provides a complete MIME
+implementation, and drivers for individual messaging protocols, known as
+providers, can be plugged into the JavaMail framework dynamically.
+Several providers, implementing Internet standard protocols, are
+included with GNU JavaMail. These include:
+
+* SMTP, IMAP, POP3
+* NNTP including posting to news servers
+* The UNIX mbox format
+* Dan Bernstein's Maildir format
+</longdescription>
+</pkgmetadata>